Weird problem with an object

Hello! I have a problem with a cube object, although it doesn’t really look like a cube. As you can see in the first image, the right barrier shows correctly the arrows forward. So I copied it, moved it to the left, but the arrows point backward. What’s simpler right? Just a small rotation needed.

Well not really… As soon as I rotate it… the texture becomes black! I tried putting a small light point, but still black, so lighting doesn’t seem to be an issue ( and it shouldn’t ).

If I move it, the texture becomes visible in the editor. However after I build the lighting again, the texture becomes black!

The material I am using:

Has anyone faced a similar problem before? If yes did you find a solution?

There might be several reasons for that:

  • your mesh has negative scale (could be mirrored in 3d package?)
  • UV coordinates could be mirrored
  • something wrong with the normals
  • lighmap UVs could be overlapping (or could be mirrored)

Hmm thanks for the answer, although I am new to game developing, this is my first game so I barely know what to do next. Do you have any suggestions? The mesh scale is not negative, but the x is 0.0001 as you can see in the image.

Try to scale this up and re build the lighting… Scale like 0.0001 is something like 1 mm I think.
Probably changing the shadow bias in your light could help… but I don’t really know if that’s the reason, since other side (not rotated) is ok…
How does it react when you rotate the directional light the other way and re build the lighting? Maybe you didn’t plug the directional light to the sky, so there is no ambient light, and the unlit side results black?

It turns out to be a light problem, I added a second directional light to aim at the object, and now it has light! I am not sure how to setup my light properly though, I tried a few things but it doesn’t seem to work. Any tips?

This is weird. Check out this picture:

Only 1 directional light is enabled in this scene.
The only solution I have is to use more than one directional light to light the black barrier. I don’t think this is supposed to happen thought.

To light properly an exterior you need 4 things; SkySphereBlueprint, Directional light, Reflection Sphere and Skylight.
Select the SkysphereBlueprint and add the directional light in details panel under “default” properties.
In world Settings you should also set the environment color to something bright (I don’t remember what color is on default).
I wish to have more time to make some proper tutorial for you, but I think you should search something on youtube.
At first why don’t you start from one of the projects that Epic provided to see how things are set. Best for investigations is “Blueprint” project, that is available in Learn section of Epic Game Launcher.
You will find there Post process volume, World settings for lightmass, how the; SkySphereBlueprint; Directional light and Skylight are set up… and so on.

It’s not a good idea to start learning on empty project. I’m telling you from experience, I had to see how people do stuff, to recreate it on my own.

Good luck. Keep it up.

Thanks so much my friend. Seems like I didn’t have the “Sky Light” ! I still need to tweak the settings though. I think I will check some more tutorials. Thanks a lot for your help!

No problem :wink: