Weird physics body bug/problem in Ue5-0 (Help pls)

After remaining idle for a while, the simulated physics bodies just freeze in place and as you can see in the video, never unfreeze. (It happens at 00:18 seconds)

video: 2022 04 08 16 10 03 - YouTube

Thanks for anybody that can provide some insight into this, I tried everything and I have no clue why this is happening. Thanks

(I tried just setting any other physics body to simulate and the same happens…could this be an actual bug in the engine?)

(also sorry for a bit laggy video, obs destroys me)


I got to bump this, I still didn’t figure it out

1 Like

I am also having this bug, it seems to happen whenever a physics object gets to an idle state. I tried setting up a debug print string to see if the physics objects were going to sleep but it doesn’t print even when the objects get stuck in space so I have no idea.

Same here.
I have a dumb way to fix it.
Basically, just awake the body physics anytime.
If you can find a way to detect when it freezing, you only reset all bodies after it.

And wait until EPIC fix this bug.


Yeah, it seems to be a bug within the new engine… I’m sure they will release the fix soon, until then we gotta do with our little fixes haha

1 Like

The bug hasn’t been reported, has it ?

Interesting, I thought I was just bad and doing things wrong… Have a post about this too, my physics body keeps getting stuck out of no where…

How do we go about reporting and making sure this is taken care of? Do we need to all vote on it together or something?

Sadly that fix did not fix it for me. =/

EDIT* I did find a different fix it would seem. Instead of reseting the physics body, instead apply just a small amount of force to it to keep it active but not noticeable.

1 Like

I haven’t reported it yet because I was wondering whether it was just a setting that I had messed up.

Same problem here.
Has this been reported ?

I ran into this while adding grab interaction. Once grabbed, the object wouldn’t move until I bumped into it. I added a Wake All Rigid Bodies to the Break Hit Result. It works for my case but seems odd.

Its actually the cleanest solution we have, I use it with a looptimer (0.25s) but Epic need to check this.

Not fixed in 5.0.2

1 Like

Can you check if this helps p.Chaos.Solver.SleepEnabled 0, i have different bug with sleeping and this helps but its temporary solution

1 Like

Oh snap, great find! I just added it to my level blueprint and it works wonderfully.

1 Like

If you are trying to accomplish this in blueprints, you can make a custom physics material and set the sleep linear/angular velocity thresholds to 0.

If you apply that to your physics objects you do not need the wake all rigid bodies function to interact with the physic object.

The physics setting for sleep family and sleep threshold multiplier did not work for me but the physics material did.


Confirmed working for me in 5.0.2, thanks!

Not fixed in 5.0.3
(still use the Izengon custom physics material solution)

Thanks i was starting to lose my mind!

I tried that and Mesh won’t connect to Rest All Bodies Simulate Physics on the object’s BP. The Mesh is not compatible.

Okay, for me I was using the console command “p.chaos.solver.sleepenabled 0” executed on begin play and it was working all the way until update 5.0.3 and now for some reason console commands are not executing or at least not visible in “ingame” console.

Just wanted to report that to see if some of you had similar issues now?