Download

Weird LOD issue and screen size

Not sure if I’m the only one but somehow I cant import a complete LOD package. I tried it exactly as the video below

Software:
-3d max design 2012

  • fbx version 2013 and 2012
  • Unreal Engine 4.7.6

If I follow that guide UE will only import 1 model from a package IF I press (Combine meshes), If I uncheck that it will import the meshes separately.

HOWEVER, what I can do is import 1 model/asset and then in the [content browser]
click on that asset press the [RMB] and select <Import LOD> → <LOD1>

importlodhuh.jpg

And it will be added to that asset. Can someone tell me if this is a VALID way of making LODs in UE?

There is one small issue though, I can not change the screensize per LOD, they seem to be greyed out. Any solution for that?

screensize.jpg

Hi papigiulio,

The video linked above is an accurate way to import LODs into UE4. I’ve got a written tutorial in one of my threads on the forums here: https://forums.unrealengine.com/showthread.php?56777-Photons-Be-Free-Mini-tutorials-and-other-curiosities&p=227697&viewfull=1#post227697

As for the right-click context menu to import LODs, this is also a valid way to import LODs. This option is also included in the Static Mesh Editor under the LOD Settings tab.

To change the Screen Size you will need adjust this in the same LOD Settings tab by removing the checkmark next to Auto Compute LOD Distances. This will allow you to set the screen size for any imported LODs.

I hope this helps.

Tim

GAH! It was animation! Just saw it in your tutorial.

Animation needs to be checked in order for lods to be imported properly.

Thank you so much. :slight_smile: