Download

Weird lighting bug

Hello. I’m working with the ‘RealisticRendering’ scene, and, after importing a custom mesh, I’m running into a very weird bug:

Here’s the first version of the mesh:
HighresScreenshot00000.png

As you can see, there is a weird color in the center. However, just by deleting a few vertices in blender:
HighresScreenshot00001.png

It looks waay better. Lighting has been built in both cases, and the materials are simple colors. Any ideas on how can I get the first mesh to work, or what is causing the bug?

Thanks in advance

I don’t think it’s a bug. Bad modeling might lead into bad result.

Can you show us your model and the UV maps? That’ll give a good idea of what’s happening.

Here are the FBX:

https://mega.nz/#!y5lWXDJL!_gkrX1ROs0-qsaNsvBuggS5tXMB6t7yB1P0RJBzfAcU
https://mega.nz/#!y1cGRapR!xxVfSYye42MWzpcixYv2lULTpg137u4vEvAPOtW8UeM

And the UVs:

Not working mesh:
Armchair_NotWorking.png

Working mesh:
c6998ba1cc6e86bccf8c64767cd6cbed917c4b30.png

ad2mesh, looks like you have some ideas in how could I improve the models. Could you please share them?

you export your fbx without smoothing group obviously when Import UE4 its pop up a warning!
e666f157067f62bd820be5fca7e2ebb2f8465f54.jpeg
here a link u can read staticmesh pipeline:

Thank you very much! :smiley: I thought that it wasn’t necessary as all of the meshes faces are flat. It still had some minor artifacts, but they disappeared by increasing the lightmass resolution.

Still, even if it looks good, it looks rounded. I’ve tried setting different export/import options and messing with the mesh in my 3d application, but looks like I can’t get the faces to look perfectly flat and perpendicular. Anyone has experienced this issue?

If it looks rounded, then you are using just one smoothing group. Try to use multiple smoothing group, AutoSmoothing in Max, to get flat and perpendicular look.