Download

Weird issue with long times for constructing

I don’t know what exactly the problem is, it’s just very strange.

I have an actor where some stuff (including traces) is done in the construction script. The construction script needs 10ms to run. But if I update the location of the actor in the level, I have to wait 5 seconds before the location was updated. This is already strange, since if the construction script runs fast, why should the updating of location takes so long?
Now it get’s really weird: If I change some stuff in the construction script (different way of handling variables) it needs 20ms to run but doing the same, but now I can update the location of the actor in the level without waiting 5 seconds (more like 30ms).
The exact same amount of traces is done, everything is the same, except how I calculate variables.

What exactly does the editor do in this 5 seconds of updating location is construction script only takes 10ms? :confused: Actually during the 5 seconds one CPU core is at 100%.

I’m trying to find this out the last 2 hours… I just don’t get it.

Can you post some code to look at?

Regards

Narg

The “code” is really not important here, it would just confuse you :cool:

NP, I hope someone will be able to help you out.

Regards

Narg

Ok, clearing all local array variables of the construction script at the beginning of the construction script fixed the problem. Still no idea why, and it still doesn’t make any sense that execution needs 10ms, but it’s fixed now.