Download

Weird GI glitches?

Currently i’m making a set of lamps that have a silicone (subsurface) material,
However after i bake a static light both the SS effects vanish and there appear some really weird shadows.
Is this a known problem? and is there a known solution?

wmCZ3fA.png
The light itself is a white omni lamp with default settings
The GI was baked at production level

Hi remember that sss wont show up with static lights use stationary instead also it is better idea to use emissive material in this case to fake sss, for the artefacts try to up scale light map resolution and/or set render quality to production there are couple settings related to light quality in the world properties. Another thing that is worth to check in case of artefacts is uv setup (if you using SM for walls) and avoiding intersecting geometry

Thanks for the quick reply,
I already “boosted” some of the lightmap/GI settings, and im always rendering in production mode, the walls are meshes with 1k lightmaps with manual lightmap UV’s.
The reason i tried static lights was to see if it would cast transluscent light through the lampshade, though it did not… so i guess i have to fake that.
Is there a way to disable shadowcasting for 1 particular light in relation to 1 particular object? (similar to lightlinking in maya)

you can switch object to movable so it wont cast shadows from static lights but will cast them from stationary lights, it might be good idea to increase density of volume light samples (to improve dynamic object lighting). What you can try as well is decreasing lightmap smoothing as well, 0.65 usually works good with high quality light settings. when it comes to artefacts check witch uv channel is used for storing lightmap information or replace static mesh wall with unreal geometry.

That’s some odd shadowing… perhaps the padding in between some of the faces in the UV map are overlapping or not spread far enough?