Weird Color Problem in editor

I installed NVidia drivers on Linux mg-Ubuntu 3.16.0-45-generic #60~14.04.1-Ubuntu . Here is screen shot from GTK;

And also in here is from Nvidia settings;

However when I tried to use Unreal Engine 4 in my Ubuntu graphics are not good. There are lots of weird colors are appearing. Here is image from Unreal Engine;

Here is another example;

Then I go and check lspci and glxinfo whether my nvidia is working correctly or not. And see I have hybrid graphics

   mg@mg-Ubuntu:/.1/Programs/UnrealEngine/UnrealEngine-release/Engine/Binaries/Linux$ lspci -knn | grep -EA2 'VGA|3D'
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
	Subsystem: Lenovo Device [17aa:3912]
	Kernel driver in use: i915
01:00.0 3D controller [0302]: NVIDIA Corporation GF117M [GeForce 610M/710M/820M / GT 620M/625M/630M/720M] [10de:1140] (rev a1)
	Subsystem: Lenovo GeForce 720M [17aa:3912]
	Kernel driver in use: nvidia

And also OpenGL renderer is GeForce not MESA

mg@mg-Ubuntu:/.1/Programs/UnrealEngine/UnrealEngine-release/Engine/Binaries/Linux$ glxinfo | grep OpenGL | grep renderer
OpenGL renderer string: GeForce GT 720M/PCIe/SSE2

How can I solve this issue? Why I see such weird color in my editor?

I recommend getting these drivers: Linux x64 (AMD64/EM64T) Display Driver | 343.36 | Linux 64-bit | NVIDIA Older drivers contained bugs (see the readme in that link for the details).

However I didnt use ./ for installing driver… Actually I tried and my computer crashed with black screen then I installed from repository(I dont know ubuntu dictionary, in Centos we call it repo. like apt-get install xxxx)

You don’t have to install .run, just use xorg-edgers PPA.

could you give me command line please?

I couldnt install nvidia-343 because WARNING: the "nvidia-343" package was deleted from this repository here is the link :