Download

Weird Collision Glitch [VIDEO]

First of all - not sure if this is the correct place to post this, and I’m sorry if it isn’t. I have this door in my level, that is very problematic. The thing is, that the floor of one side of the door is a bit higher than the other, making the transition between the two doors similar to a stair step. Here is a collision picture so you can see there is no collision in the way :

Next, the settings on my first person character. I bumped these to some extreme settings, but the problem persists :

DoorCollisionGlitch1.png

The problem is in the video :

When I try to go in, no problem. On the way out, it gets all weird. If I try to go from the center of the door, it won’t let me. It’s like I’ve hit an invisible wall. If I try to go from the left side, it sometimes will let me, other times not. If I go from the right side of the door it will always let me. That is only if I hug the door frame. I have NO clue why this is happening… These settings should allow me to step on top of a wall (90 degrees walkable angle) and the difference in the Z axis of the two floors is extremely small too - we’re talking like 2-3 pixels. Help please!!

Bumping this, still need help!

What’s your players collision like as far as added components camera boom etc etc?

Isolate it remove the door frame and door and see if it’s the door. Could be a one sided material that has collision?

Are you using a convex collision? My guess would be that the collision shape on the doorframe is slightly narrower on the other side, so you get this behaviour. Try to go into your doorframe and replace the convex collision with 3 box sized collisions. Put one on the right side, one on the left side and one on the top of the doorframe. Remember to have enough room in the middle of the doorframe to fit through.

It is not the door - I’ve used the exact same door model and frame model numerous times, this is the only problematic bit. Also, this happens when I try to get into a vent that’s a bit further.

I’m using a ‘Use Complex Collision As Simple’ on everything in that specific scene (door/frame/wall/handle).

I just tried isolating the problem, and it was the floor. Because I have my level set up with custom collision I’ve made in the 3D program, it’s a bit weird. I have my room layout, that has no collision and the same layout made out of basic boxes that are invisible. Problem was, that one of the invisible boxes (the one used for the floor) was set at Z - 1900 while the other floor part was at 1902, but I really didn’t think 2 pixels would be the difference… So the character cannot go 2 pixels up if they’re at a 90 degrees angle? Why is that, I’ve set all the settings to very high as I’ve posted above? Is this a potential bug?

Alright, managed to fix my vent problem as well - had to add an invisible slope-kind of thing next to the vent, so the character can smoothly go up to the level of the vent… This is quite frustrating though - my character won’t go up even a pixel if it isn’t a smooth slope.

Look in static mesh for setting for can character step up on