Download

Weird behaviour with player controller

Hello all,

I have a problem that I hope someone can help me solve.

Mind that I’m pretty new to UE4, specially in using blueprints and interactions, so this “weird behaviour” is probably newbie issue.

I have a scene with a object that I want to rotate with my mouse, dragging mouse left, object rotates left, dragging right, object rotates right and that’s working perfectly. I also want to have my cursor showing when I’m running the game, and there’s where the problem exists.

I created a specific Mouse_PlayerController with the the Show Cursor checkbox ticked, but when I run the game, the rotating object function only works the first time, so as soon as I release the LMB it doesn’t rotate the object anymore. This only happens if the cursor is showing, so I have no idea what’s is happening here.

I hope someone can help out on this. Thanks

Do you have any user interface elements that you can accidentally click?

You can try setting your input mode to game only, using the PlayerController blueprint node Set Input Mode Game Only. If it works then, then you know the problem is caused by a UI element.

I don’t have any UI elements in my project, unless I accidentally activated something somewhere. I say this because I tried to create a new level inside the same project and I get the same results, but if I create a new project that problem doesn’t happen, so it’s something I’m missing.

Thanks for your help though, I’ll try to do what you suggested, even though I’m still trying to understand how to do that :D.

4.11 bug slated to be fixed in 4.11.2 (ShowMouseCursor = true causes mouse x/y to be 0/0 under certain circumstances)