Download

Weird behavior: objects jump in the editor on simple move

Hi!
I need help. When I move mesh or any other object in the scene it jumps. Looks like it’s trying to stick to some kind of invisible grid. But I have surface snapping turned off. Please, check the video below.
Also, I noticed that the jump happens at the moment when object and/or mouse cursor intersect another object.
It feels like I switched something on in the editor, but I don’t know what and how to turn it off.
Do you have any ideas what could it be?

https://youtube.com/watch?v=t4s9ZWTModg

I see someone got rid of this by binning the config/saved folder:

https://answers.unrealengine.com/questions/535892/editor-move-tool-jumping-around.html

Yes! I’ve just come here to write that I found the solution :slight_smile:
Cleaning Config & Saved folders worked for me!

There’s also an option in the Actor dropdown for the selected actor to change how and whether it spawns when detecting collision with another object.