Webcam live video doesn't work (black) on some of my machines

This is probably something stupid…I followed the Playing Live Video Captures | Unreal Engine Documentation tutorial and setup a live webcam into a sample unreal project on my work machine and it worked great. Then I went to my machine at home and did the same thing (with the same webcam) and I don’t get any video, just a black screen.

The “camera” app in windows detects the camera and shows video ok. In unreal the webcam shows up in the MediaPlayer asset list of sources but when selected I just get a black screen and the activity light on the camera does not light. On my work computers (2 of them) it works fine, camera light lights up and I get video as soon as it is selected in the Unreal Media Player asset.

Is there some Unreal Editor plugin or setting that might not be enabled on my home machine that would stop the camera from working?

The install on my home machine is a fresh 4.22.3 unreal on windows 1803. Same setup on my work machine, but that one has been used a lot more. The camera (logitech pro hd 920) did not require any driver installation to work on my work machines.

Any suggestions how to debug this, seems odd that it works on windows camera applications but not in unreal.

1 Like

Hi Greg,

I wonder, did you find a solution? I am having the same problem - black live video feed although the camera should be working and is working in other applications. I’d highly appreciate to hear if you found a solution. Thanks and all the best,


I still have some issues with this. The specific fix for the webcam issue I don’t remember, it might have just gone away when I updated to the latest unreal. I HAVE noticed that sometimes unreal is just picky. There are a few video capture cards that work fine with a lot of applications but not unreal. For example NDI (video over ethernet) has a thing that is supposed to make an NDI camera show up as a WMF (windows media foundation) source that Unreal should support, but I haven’t got it to work. Works to stream video/audio from my iPhone to skype, google hangouts and other stuff, when I try it in unreal it seems to recognize that there is a video feed there and opens it, the tally lights on the phone light up, indicating that unreal has opened the video source up…but on the unreal end I just get black…though the time in the playback window keeps moving forward like it was getting frames.

Hi Greg,
did you find a solution? I am having the same problem now.
I connected a webcam to a laptop. So the laptop has actually 2 cameras (internal + usb webcam)
When I enumerate them, both are found, but only the usb webcam can be used, the internal one always returns black in unreal.
I am using UE 4.24.

for everyone who faces the same problem, I finally found the solution.
The webcam that does not work returns actually 2 video tracks.
So all you have to do is to use the “Select Track” Blueprint function of the Media Player and set it to “video” and id “1”.
Be sure to also add a delay after OpenUrl before switching the track and after Select track before executing play again.


Yes, this is sometimes the problem. Also sometimes you have to select the format or you may not get the resolution you want. One of my webcams generated 300+ different video formats and the default one was NOT what I wanted (very low res). So in the end you want to enumerate video devices like you are doing and set the right track/format.

Sometimes though, the capture device just plain does not work even though it shows up in the media player menus. All you get is black and there are usually no tracks/formats available when you enumerate them.

I’m having this same issue in 4.25. I tried [USER=“1102928”]B REX[/USER] 's method of selecting the video track but still no luck.

@Greg.Corson I’m interested in trying your solution regarding selecting formats. Can you please explain how to accomplish this? Thanks!

hi, faced same problem with webcam not playing and black screen
tried method with track selection and found 1 issue - put delay not less than 2-3 secs before selecting track, as enum takes 1-2 sec to return tracks value

all i did was check Loop under playback in details
selected snap cam or splitcam on the right hand side there is a tab that says details
Details >>> Playback >>>> Loop Check
everything worked great after that
andriod user

If Unreal detects your webcam on the upper left icon, try to change the videoplayback settings (in the lower right). Mine got correctly after I did this.


you must set dircetx 11 in your project setting.