Web UI (HTML/CSS/JS Interface Widgets)

If you want money for this plugin than sell it on Unreal Marketplace, thats all.
Youre sharing this plugin for free than soo what is your problem to help community?
You don’t have to be rude…

First off, I edited my post before you replied. Second, since you’re still responding to my original post that isn’t there now, I find it crazy how in my original post I literally said that this plugin was on the marketplace 6 years ago and stated that “it cannot be sold on the marketplace because you cannot have plugins that depend on other plugins” and yet that’s apparently too complicated for you to figure out. Oh really? Sell it on the marketplace? Wow what a genius idea dude, that never occurred to me!

And you wonder why we don’t care to help anyone anymore. It’s like, how do people like you even figure out how to download and use this engine in the first place. There’s just no way.

Yeah, you edited your first reply because you’re trying to sell me a free plugin for 100$.
I was just looking for help and what you doing is just mad replying.
If you dont care anymore to help people than close this topic for comments…

Wouldn’t it be better to just answer “Hey, if you want any help, you need to buy our plugin for 5$ on our site”…

Hey @spidershift,

I would like to buy WebUI plugin but when I try to click on the Buy button on your website there is an 302 error on Sign in to GitHub · GitHub and website is redirecting me to main page of orders Sign in to GitHub · GitHub

FYI: I am logged in, connected github account to epic

Here you have a picture with a network details of this request

Can you check it? Thanks a lot!

Hey Hey Hey @spidershift

Went to snag the paid version as well and having the same circular issue as @szmski above. Everything is connected with Github, we’ve downloaded from there in the past and can see my Git Name in the /orders/ pages but just says empty and no option to purchase after clicking the Buy Now.

Was going to donate once we were ready for release but this is a-ok so now or later, all good in our book! Thanks for all the hard work…UMG just sucks and webviews rock!

Hey @spidershift , I cant buy anything on your website, it redirects me to the orders page that says : “You do not have any order history…” I’m logged in with GitHub and git is connected to my epic account

1 Like


“中 国 人 都 是 抄 袭 者”(All chinese are copycat)。我看见你的文档里有这个,说实话我本来懒得跟你理论的,毕竟你的这个浏览器也是从google chromeium那儿抄袭下来的,要说不要脸的话,我觉得你首当其中,借着UE5和开源浏览器的光来骂中国人干啥?有什么必要。你要骂人没问题,你可以用你的母语骂,但是不要以为学了几个汉字就很上档次了。

5 Likes

Hey @Aricwithana and @juliusD, sorry you’re having trouble with the website. There’s a special check that requires GitHub accounts to be linked to the Epic Games network before receiving full access to order and download. However there apparently was an issue where it was not detecting this for some accounts.

This problem has since been fixed, and you shouldn’t have any more issues. We’ve also included our contact information on the orders page in case you run into any other problems.

1 Like

seek help:LogWebInterfaceBrowser: Error: Accelerated CEF rendering selected but OnPaint called. Disabling accelerated rendering for this browser window.

1 Like

Hi @spidershift
I wanted to use the plugin on a mac and wasn’t able to get it running. I used the free_trial versions provided under the git. I tried to add them to the plugins folder (both the projects as well as UE 5.1) but as soon as I started with those files in there I wasn’t able to launche the project anymore.

I also tried to compile the plugin manually in order to get binaries for Mac but that didn’t work either as only Win binaries were created.

I was wondering if you could help me with this. Any help here would be greatly appreciated as I think this plugin can give me access to many of the text features available in html5.
best regards

Hey @DavidRiez the downloads on GitHub only include trial versions for the Unreal Editor on Windows. There are no Mac binaries provided. I’m not sure how you tried to manually compile the plugin because there is no source code provided in the trial downloads. You will need to get the source code from our website. After that you can follow the instructions at the end of the documention for the Rocket command to build the plugin. Don’t forget to edit your .uplugin file so it only has the platforms you want to compile for, which again is detailed in the documentation.

Hi @spidershift ,
thanks for the quick reply. So, if I understood you correctly that means the trial version doesn’t work on mac but the paid version does? And there is also a description how to build the plugin for the mac editor in said paid version?

  • I have the same problem!~~~ [support me]

LogWebInterfaceBrowser: Error: Accelerated CEF rendering selected but OnPaint called. Disabling accelerated rendering for this browser window.

WebUI Plugin is enabled , The page can be loaded but the rotor page cannot be jumped .

1 Like

@spidershift You’d better explain this matter. Are you a racist? This is very detrimental to your sales of the plugin.

I don’t like to keep harping on the same topic, but I was reading the news this morning and ironically came across these articles discussing a Pew Research poll that just came out:

It seems most of the world hates China these days. Perhaps it’s your foreign policy of not respecting international waters and making constant threats; or maybe, just maybe, people didn’t forget how you unleashed COVID-19 on the world and started a global pandemic. I also find it extremely disappointing that the world has yet to cut you off completely. We should’ve imposed heavy sanctions on China and destroyed your economy, or at least, moreso than what you already did to yourselves with your “Zero-COVID” policy.

The other thing I find so hypocritical is how you have the audacity to try and label us as racists. For instance here’s a picture of some U.S. service members:

U.S. Military

And here’s a picture of some Chinese service members:

Chinese Military

Anyone notice anything interesting there? When I look at the U.S. military I see people of all different races, because the United States embraces diversity. And when looking at the Chinese military; I see literally no white people, no black people, no hispanic people, no middle-eastern people, nothing. So guess what @C_69 if you want to see a racist then maybe you should go look in the mirror.

No offence. Just want to know what happened before I pay.
I thouht someone had pirated your works and it makes you mad. But it turns out that you are hating for other reasons. Apparently you are not intrested in furher research on China, so that’s it.
Anyway, eventhough you won’t care, respect to your contribution to unreal community and respect your choise to not offering chinese devs this plugin.

Yes, our works have been pirated, many times! We’ve had to DMCA at least 10 different items on the marketplace over the past few years, and guess what? Every single one of them is a Chinese ripoff, because the Chinese are total pieces of ■■■■ that don’t have any respect for international copyright laws.

That’s why, as game developers in the shooter genre, we will, now and forever, ensure that the People’s Liberation Army are categorized as terrorists in our video games. We want to make sure we desensitize all the youth in the Western world to eliminating the Chinese threat around the globe. So we will continue to provide them with the opportunity to kill Chinese soldiers, over and over and over.

The plugins have been updated for 5.3 on both GitHub and our website…

WebUI - 5.3 - 5.2
JsonLibrary - 5.3
HttpLibrary - 5.3

There are also some updates worth noting:

  • the pak:// scheme has been removed and replaced with a http://game.local/ domain listener instead
    • this fixes an issue with local font files not loading due to CORS restrictions
  • the Accelerated Paint setting has been disabled by default due to the CEF not supporting this feature in DX12 (so we will have to wait for a significant CEF update)

Did you know that America is a nation of immigrants…

I’m getting clang++ duplicate symbol errors when trying to package a project on Ubuntu.

ld.lld: error: duplicate symbol: CefLogSeverityToWebBrowser(cef_log_severity_t)

Apparently defined in CEFWebInterfaceBrowserWindow.cpp and Module.WebBrowser.cpp.
Using the latest version of the plugin for 5.2 on Ubuntu 20.04.
I just put the plugin into my projects Plugins folder.
Did I miss anything? Do I need to built the plugin or the engine from source?