Download

Weapon won't attach into socket

Hello everyone! I’ve tried to create a blueprint which allows me to attach a weapon into a socket in the skeleton. I’ve tried to overlap the weapon but nothing happens.
This is the blueprint:
d47f3f834fc28bde0c56a834ffcf9c611f2e6401.png
a300115042d2db0b3bf604f778eef88f124cf405.jpeg
Does anyone know why is this happening?

-Chers, Dom

Anyone? Please.

https://www.youtube.com/watch?v=fyC57urfKtE this link should help , also if you have a pickup weapon system take a look here for some help Joe Hudson - YouTube :slight_smile:

Have you made sure to create a socket on your skeletal mesh? Also I think it might be case sensitive so check your spelling. Also there are a few different attach functions the way I got mine to work was with attachTo hook it up to a begin play event for testing, as it could be something to do with overlapping. If your overlapping don’t forget to set it to overlap pawn. I could be wrong but I think attachToComponent only works if it’s a child of the actor whose component you want to attach to. Try AttachTo instead, can’t test it cause don’t have a computer at the moment

Thanks for your answers guys. So I tried to add one more node to destroy the actor once overlap event is called, nothing happened. I removed the BP for picking up the weapon from the level and I placed it again. Now the weapon gets destroyed but it still won’t attach.
This is my socket:
8ae82deb64a20dac1d2380fe1d0df7bc5573ff9b.jpeg
Modified weapon pickup BP:
3.png
I tried to add attaching weapon to the level BP but I can’t get a reference to the weapon in the BP editor:
90d6ed6410e192c4157cf360f30bae5f5863d978.jpeg