We need clear guidelines to solve 4.10 installation errors

I have the error code 1638 when I try to update my 4.10.0 to 4.10.1.
(at first I got another error code but now its always 1638).

I already did read and try the many “solutions” suggested here & there but I’m still stuck with this error.

Windows 7 is fully up to date.

I tried uninstalling Visual C++ 2015 prior to installing 4.10.1
I tried starting epic launcher as administrator.
I also tried a manual install of the pre-req prior to installing 4.10.1
I tried various combinations of all that.

Maybe I missed it somewhere but a clear guideline from Epic to better understand and solve those 4.10 installations issues would be very very much appreciated.

Thx !

Hey Beatnic-

Can you provide the full error that you’re getting? Also, are you trying to update a binary version of the engine through the launcher or are you using a source version? If you are using source did you get the download from the 4.10 branch on GitHub or the Release branch?

Cheers

Doug Wilson

I found the solution, altho I still think we need some reference document to deal with the 4.10.x installation issues.

2 days ago I installed 4.11.0, without any problems.

1 day ago I tried to update my 4.10.0 to 4.10.1 : install failed with 1638 error code.

Here is the problem, as I just found out :

  • The pre-requisite for 4.10.1 (version 1.0.10.0) is older than the 4.11.0 pre-requisite (version 1.0.11.0, if I remember well).
  • During the install process of 4.10.1, the launcher attempts to install 4.10.1 pre-requisites.
  • The 4.10.1 pre-requisite exe file refuses to install if a more recent version is already installed on the system. (although its possible to do a manual install of the pre-req by the mean of the .msi, as I did before, but it doesnt help in the end).
  • The 4.10.1 install process fails.

I uninstalled 4.11 pre-requisites files and the install process of 4.10.1 finally went fine.
Now I’m wondering if I should re-install the 4.11 pre-requisites. Any input from Epic support on this matter would be really helpfull.

Hi Doug

Thank you for your input, I just answered before I saw your comment.

Full error, as I remember, was “error code 1638”. It occured soon after the attempt of the pre-requisites exe to install.

I was trying to update by the mean of the Epic Launcher.

Problem is solved for me, for now, (see my answer to my post) but I’d be very interested to know if I should re-install the 4.11.0 pre-requisites.

Thanx

Can you walk me through the install process you used? Are you building through the Launcher or from source? What exactly are you referring to when you mention the prerequisites?

Sure, here are some details.

  • 2 days ago, I had 2 versions installed : 4.9.2 and 4.10.0. I decided to install 4.11.0 (preview1) from the launcher. Everything went fine. At that point I had 3 versions installed : 4.9.2, 4.10.0, and 4.11.0

  • Yesterday I launched Epic Games Launcher, saw there was an update available for 4.10.0 and decided to update (from the launcher) to 4.10.1.

The process of installing 4.10.1 failed. I got an error 23… something, I cant remember the exact code.

  • After reading the different solutions suggested here, I tried the following : update Windows 7, uninstall Visual C++ 2015, re-install Visual C++ 2015, etc.

None seemed to work, but the error code changed from 23… something to 1638.

This is how I found the solution :

  1. I noticed that the update process of 4.10 always failed after the attempt from its pre-requisistes exe file to install.

I’m talking about “UE4PrereqSetup_x64.exe” located in “\Epic Games\4.10\Engine\Extras\Redist\en-us”.

  1. I also noticed that another “UE4 Prerequisites (x64)” has been installed the day I installed 4.11.0. This one was version 1.0.11.0, while the pre-req file of 4.10 is an older version : 1.0.10.0

  2. Since UE4PrereqSetup_x64.exe doesnt want to install if a newer version is already installed on the system, I tried to uninstall the “UE4 Prerequisites (x64)” version 1.0.11.0 before I tried to install 4.10.1. And that time, it worked.

In short :

  • It seems that “UE4PrereqSetup_x64.exe” cant install during the update process if a newer version is already installed on the system.

  • 4.10.1 update seems to require the installation of “UE4PrereqSetup_x64.exe” located in “\Epic Games\4.10\Engine\Extras\Redist\en-us”.

  • So, if 4.11 is already installed, along with its own “UE4PrereqSetup_x64.exe”, wich is newer, then 4.10.1 wont be able to install.

Solution : un-install the 4.11 “UE4PrereqSetup_x64.exe” before updating to 4.10.1

My question : should I expect problems related to the 4.11 pre-requisites uninstallation ? is it usefull to re-install the 4.11 “UE4PrereqSetup_x64.exe” ?

Have you been able to use 4.11 since getting 4.10.1 installed? Since you were able to get 4.10.1 working I would make sure that 4.11 is still working. If you do have any problems then it would likely help to run Verify on the 4.11 preview to try reinstalling the prerequisites. If there are any problems after that then you’ll want to create a new post to keep both issues (updating to 4.10.1 and the 4.11 prerequisites) separate.

Yes I can launch 4.11. But I dont know if I should expect problems at some points due to elements missing from the pre-requisites of 4.11 that I uninstalled.

What is “Verify” please ? Is it required or can I just re-install 4.11’s pre-requisites directly from the exe located in “Epic Games\4.11\Engine\Extras\Redist\en-us” ?

Verify is an option in the drop down list under the engine version on the Launcher and is used to ensure that the engine is installed properly. You can run the exe however the Verify option should do this as well.

good to know, thank you Doug !

Beatnic how did you uninstall the UE4PrereqSetup_x64.exe?
I can’t find it in the Uninstall programs in control panel. Is there another way to get rid of it?

I have a line in the programs list from the uninstall contol panel :

Name : UE4 Prerequisites (x64)
Editor : Epic Games, Inc.
Version is 1.0.10.0

Maybe something has been modified regarding the prerequisites install/uninstall since my last message here ?

Hey Beatnic-

I’m not sure I understand what you’re asking. Are you having other install issues after updating 4.10.1 and installing the 4.11 preview? For clarity, can you elaborate on your question please?

Hey Doug,

Thx, I wasnt asking anything, just replying to Chimp’s question, posted 7 hours ago :“Beatnic how did you uninstall the UE4PrereqSetup_x64.exe? (…)”

@Beatnic
Solution : un-install the 4.11 “UE4PrereqSetup_x64.exe” before updating to 4.10.1

This worked for me! I had 4.11 Preview 5 and need to install 4.10.2