WaterBody Plugin in 5.1 issue

I’m trying to create a landscape with water and thought it would be a good idea to use the water plugin.
However I can not get the different types of water to transition well between each other. It always creates a seam between the river, ocean, and lake components.
Is there any way to solve this or is the WaterBody Plugin just broken?


Hey @AlxCatz, Welcome to the community!
How do you have your splines set up for the water system?

The first one got fixed after I deleted it and put in another one after a restart.

For the second one it seems like the seams occur between the river part and the transitional area that is supposed to blend between river and the other water bodies.

I’m having this issue as well, with the bonus issue of any “thin” streams being completely broken up. Anything less than 512u thickness has resolution issues. I feel like this has to be tied to adding HLOD support to the water plugin.


My river splines worked beautifully pre 5.1 (even back in 4.27). Any help here would be much appreciated.

Hey ya’ll, I solved my issue and perhaps it’ll help you too:

With 5.1, you should see a WaterMeshActor WaterZone added to your level when you use the plugin. By default, it looks like the resolution for the WaterInfo texture is set to 512x512, which I believe is lower than the original default. In addition to that, it’s entirely possible that your Zone Extents aren’t set to the right size. These should cover the bounds of the landscape tile that your water bodies are being drawn. (In my case, the entire landscape)

Boosting the resolution to 1024 (or 2048) and making sure the Zone Extents were the correct sized fixed my rivers and lakes. Hope this helps!

Hi! We had exactly same issue and we also solved it by resolution boosting.
It fixed it but only in editor. After packaging project gaps on the river returned.

We tried many resolutions and parameter sets but nothing helped. Does the packaged version work for you?

UE 5.0 didn’t have that issue.