Water plugin => buoyancy actor sinks in water : why ?

I have two separate projects : in one project the buoyancy works (project1) , and the other one it does not work (project2) , the actor sinks in the water.

I have checked a lot if things ( the extends landscape, world kill z , auto-activate buoyancy , … ) and all parameters seems the same between the projects (landscape, water , actor use for buoyancy) . But It does not work in project2 . I forget to check something but what ??? :upside_down_face:

I use the buoyancy example provided with the water plug-in in the both projects : BP_BuoyancyExample

Anyway I have identified one major issue : in the BP_BuoyancyExample if I activate the event “on entered water delegate” the debugger does not stop in project2. In project1 the debugger stops.

It means that the buoyancy event “on entered water delegate” is not activated in project2 : why ? :woozy_face:

In project1 it works :smile:


Perhaps an overlap event needs to be triggered. Is the water plugin using a specific collision channel for it’s water?
Maybe you need to set your actor to trigger this through overlap (or hit)

I’d compare the two project in the area of collision interaction of the floating actor.

1 Like

Buoyancy component used “pontoons” which are a sort of “sphere collision” positioned manually at the 4 corners of the cube in this example.

And these events are triggered by the component buoyancy

Perhaps you do not have the correct actor set in the debugger? (drop down of debug filter)
Are you targeting the actor in the correct world (could be many) & area (client, server)?

Check the dropdown list & how many actor instances exist there and test for the ones that have boyancy

1 Like

The project content below : there is only one “buoyancy” actor

What about the water actor? Does the plugin give you options to enable / disable buoyancy on a per “water” basis?
Maybe the water is the culprit here?

May be you are right , i have searched and compare the both projects but I don’t find this option , may be it is existing but where ?.

Select the water actor and see if it has properties regarding buoyancy either in the details panel (could be set per instance) or in the default properties if the water is a bp based of the class.

since 2 days i search /compare … I found nothing … :sob:

For your information I am not a beginner since 2020 I use UE daily to learn during one year and since one year I develop alone a game for children (6 years old and above).
I appreciate your help 3dRaven.

What about the object’s mass? Perhaps it is too much for the pontoons and is sinking it. Try reducing the mass of the object in it’s physics parameters.

@PhilippeC I never came to such a conclusion. I’m just giving you ideas to try to exhaust your options on where the problem may lie.

1 Like

The object used is the exactly the same in the both projects. I use the actor provided with plugins water (50kg).

In tutorials with this plugin they also mark the static mesh as physics actor with generate overlap events.

Thanks 3dRaven for your help , your last suggestion about “generate overlap events” help me to solve the issue.
I have checked in the project settings the collision and I found a difference between project1 and project2 in the “engine - collision” for the preset “waterbodycollision” : I set to overlap the last 3 trace type and know it works !



Good to hear you were able to track it down for future projects. Next setup will be easier for you now.