Water Plugin and imported landscape height maps won't work how I want them to.

I’m trying out the UE4.26 Water plugin and want to use my World Machine map for it.
I figured out how to make the water go “around” the high parts of the map and not specifically around the splines (under Terrain>Water Heightmap Settings: I put the Blend Mode to Max and then made the spline smaller than my map).
Yet when I want to put a lake on my map, it negates the change and makes it look like I put the Blend Mode of the Ocean to Alpha Blend.
What it looks like:
What it should look like:
I tried putting the lake’s Blend Mode to Max, but it does not work nor change anything, since (I speculate) it’s taking the ocean as the source.
When I put the Ocean Blend Mode to Min I was almost able to achieve my goal when changing the ZOffset in Falloff Settings but when I put it to a value above around 150000.0, it just makes the water disappear completely.
I already tried everything I can think of, but I came to no solution, so now I’m asking you guys. Any solutions to make the lake not destroy my map?

Currently using version 4.26.1