Download

Water - How do I exclude water in some areas?

So I am really clueless and actually depressed and frustrated at this point about this built-in water system of Unreal. I have added a ocean to my map and everything is fine and all. I got buoyancy to work fine also, but I notice the water clips into my ship sometimes while the walls of the ship is higher than the waves. So I have scoured the internet for over a week for hours a day, trying to get a zone inside my ship to prevent the water to clip in but no luck. I even watched the stream of Unreal themselves showing the Water Body Exclusion Volume and how they get it to make “holes” in the water to exclude the material and the water mesh/mask.

When I tried to duplicate the steps shown in the video, I noticed I don’t even have the same assets and also missing the “hole” parameter in the Ocean Material…

I also tried solutions of other people by adjusting the opacity etc etc, but no luck either, it looks horrible and it doesn’t work entirely because I can still see the mesh making waves…

Am I missing something or is there not a single way OOTB provided by unreal for such a common issue??..

Please can anyone help me? I need this in the future even more once I have ships with multiple decks where the player can walk around in…

I am starting to get desperate…

Thanks in advance!

Vas

1 Like