Water Body not working

Hey there! I ve been trying to use the ocean water body in UE5 but unfortunately it seems its bugged. I place the body on my landscape ( Which it has enabled “Edit Layers”) and the water renders on height different from my landscape despite my spline is aligned with it. If i delete it and add a new one, the water appears and disappears in the wrong height again. Is there something i am missing or its not ready for EU5?

2 Likes

Hey there. I am having similar issues. I think that water is bugged for early access. I guess we will just have to wait for full release.

I assume the water requires tesselation which isn’t available for now in 5.0.

It’s extremely inconsistent, I’d like to know if there is a way to actually fix it. But just to add to this, I made a landscape in UE5 and messed around with it with the landmass plugin, and added water and it was fine.

However, when I added water to a few levels I had already worked on I saw the exact same behavior described here.

To further test I made a flat landscape, added water and it worked. I tried a new level with a heightmap and it worked fine again. But opening a level I had worked on and adding it there showed the wrong height issue, and in some testing it would affect the landscape and not render the water.

So I’d say make a new level, empty landscape, add the ocean water body there, and if it works then you can probably say it’s not an engine issue.

Ever find a good fix for this?

Hello , did anyone find a solution to this problem ?

I have water + landmass plugins enabled. Also got “Edit Layer” enabled.
I made a landscape with a hole to simulate a waterfall lake. When I create a Water Body Lake, it either carves a huge amount of land destroying my landscape shape, or it sculpts a huge amount of added landscape also ruining the original shape. In both cases, lots of unwanted added/destroyed land, but no signs of water. Already check and enabled “Water Content” material, and they are there.
DOn’t know what else to do :slight_smile:



1 Like

I suspect you first need to have ‘water body ocean’ as your main terrain modifier so to speak (contrary to the name it has island on the middle) and then you can add lake to it

1 Like

Hi!
I posted this in another section of the forum already but this might help some of you so here’s a copy :slight_smile:

The water plugin is an experimental version 0.1 and has not been updated for some time. Im sure they are working on improving it. Alright info dump here goes:
The current version is meant for landscape resolutions of 4k or lower.
If you go higher than 4k you will notice once you place down a river the updating of the render target will slow down your editor heavily. Also the Ocean water itself is recommended to be at 0-0-0 world origin, the further your ocean is from world origin the more issues will arise.
The most problem free way currently of using the water system is when the landscape is completely made of landscape splines since they all affect the landscape. So Landscape->Ocean water main island-> seperate islands-> spline mountains on top-> Lakes-> Rivers. This seems like the way they currently use it on fortnite.
Now for the other way’s of achieving some use with this system in its current version.
If you only need the ocean water and dont need lakes or rivers there are a couple of ways of setting this up. I would not suggest importing a heightmap from creation of landscape, because i think the water height is set at middle of landscape height. As a normal heightmap ranges from black to white 0-1, so the water height is around 0.5. and with most heightmaps 0.5 range is already getting into the mountain ranges so your water level would be way too high. You could try to adjust the heightmap in photoshop by setting the levels from its normal 0-1 range but adjusting it to 0.5-1, but this is very map dependant and might not get the waterlevel at the correct height. Either way if this is something you want to try then import the map then set ocean water to additive, select all spline points from ocean water and set all points to location 0-0-0, this will remove the ocean landscape hole or landscape portion.
Other way’s of importing heightmaps, create landscape, add ocean water, then in ocean water settings find displacement. add your heightmap to the texture slot, set tiling to 1, set midpoint to required mid, set color channel to red(1-0-0) then set displacement height to required height of your landscape. This would allow you to sculpt landscape from the water layer itself.
There is also the option of using the landscape gizmo, under copy from landscape tools you can import heightmap to gizmo, copy data to gizmo, set gizmo settings like width height etc then place gizmo where you need it on terrain, then cntrl+v to paste the data onto the landscape.
Now for my personal favourite way currently of using the water system :slight_smile:
This is thanks to sjoerd de jong of epic games from the talk “water system deep dive”
It is a hacky method of using the landscape system without it actually affecting the landscape!
Which means you can use heightmaps sculpt and everything. And because it is still using render target it will also cut off the water on the landscape just like before.
In water brush manager you find the 2 top materials: brush angle falloff, and brush width falloff.
Duplicate those, then in the materials on both on the bottom right you connect the Unpack node to the Pack node so that you avoid the landscape changes within the material entirely.
I’l add an image for it in the end of the post.
Now replace the materials on the brush manager with those changed ones and your good to go.
Now do keep it mind that the landscape will not change on its own! So you need to sculpt the river’s and lakes yourself. Hopefully this will help some of you till its out of experimental.
^^

2 Likes

Thanks for all the info <3 really appreciate it.

This part is very unfortunate, since this is the type of workflow a lot would want to use. I know landmass & water are experimental but not being compatible with heightmap-generated landscapes is not ideal…that really rules out using the water tool for a tremendous amount of use cases

No update on this? Water is still not working with imported heightmap

December 21, 2021

sup ppl, has anyone come across a fix for this I’ve got ocean but no lakes

What caused this for me was forgetting to enable edit layers on the landscape before adding the ocean.

If you enable layers later, it might look like it’s working but it’s not. It won’t generate the edit layer properly, so your lakes/rivers won’t be able to displace the landscape mesh…so you need to enable it before adding any water to the level.

2 Likes

This worked perfectly for me, thanks.

1 Like

This is the best information I’ve found regarding the new water system and working with heightmap-generated landscapes. I’ve been searching for these answers for months.

While not perfect, these alternative methods are working great for my project. I’m using the modified brush material method and will probably make a tutorial soon. I’ll be sure to give you a ton of credit. I gave the other methods a try, but modifying those brush materials is the way to go!

Just about everyone using heightmaps seems to be struggling with the water actors, so this information needs to be available via a video tutorial. It will probably be 2 vids: One to explain the problem as you have and highlight examples, and a second with solutions.

I’ll make sure to post the videos here first. Until then, and as D13on said, the “Water System Deep Dive” video from Epic is a must-watch.

Is your lake positioned within the WaterZone actor? You can click on it and extend the “Box Extents” X & Y.

Keep in mind that the ocean-island-lake-river actors are simply landscape brush tools. If they are outside of the WaterZone volume then you won’t see any water material. Yes, you’ll see a water plane outside of that volume but I think that plane is the lower resolution “far plane” that extends into the horizon.

How big is your landscape, and do you have another screenshot?

Hello. Just started to learn UE. Trying to do Lesson.
Can anyone explain that am i doing wrong?
Water doesnt make any effects to landscape.

What water body actors are you using? Did you create your landscape from scratch, or import a heightmap?. At the moment, the water system must have a landscape. Also, if that is a water island actor I don’t think it plays nice with lakes.

Need more info and perhaps a screenshot of the editor so the outliner can be seen.

This video (not mine) covers the water system in UE5, and explains solutions to all of the problems mentioned in this thread as far as WaterBodyOcean.

For using rivers with heightmaps, maybe start by placing the river actor at the highest elevation where you want it to begin, then set the river blending to max, as done with the ocean actor.

2 Likes