Download

WASD not working anymore

Hi there,
I need help with my movement. I implemented this tutorial in my project (https://www.youtube.com/watch?v=YA1r_gwS9yg)
Looking up/down left/right with mouse works perfectly. But WASD is not working at all.
What do you need for helping me? Screenshots?
Thanks alot for your help
Regards

I would suggest watching the vid over again and double checking to make sure you didn’t miss anything. like adding the keys to the action mapping, or the scale setting of the axis mapping. Maybe a node was not connected right. Also a screen shot of the movement part of the Blueprint would help with finding the problem.


These are my Screenshots, I followed everything step by step, but even in an empty project I can’t move with my keys, just look around with the mouse, I’m so lost.

Have you tried putting values in the “world direction” like 1,0,0 for move forward and 0,1,0 for move right (or plugging values in from the vectors you have there)?

I did plug them in but nothing happens, also when I manually type in the 1,0,0 or 0,1,0.
What boggles me is, that even in an fresh project, I can’t get it to work. There has to be something misconfigured in the settings maybe?

https://forums.unrealengine.com/filedata/fetch?id=1750309

You need to connect the ‘get forward vector’ and the ‘get right vector’ to the world direction in the ‘add movement input’ (yellow pins).

I did that too, but does not work :frowning:

Does your actor have the Character Movement Component and Is your Character Actor “Possessed” by your Player Controller?

You can also set initial possession in your game mode at the default pawn class selection.

Thank you so much for your help. I implemented your Blueprint bit but didn’t get my character to move. I auto possess the player via the detail tab of the character, like said in another tutorial.
Look around with mouse works seamlessly, but keys are still not reacting. I tried again in an empty project and got it to work. Copied everything 1:1 to the broken project and again, keys not working. 4.PNG

Try adding the Print String node after the Input axis to see if they are registering. Maybe your actor is stuck in a collision from the ground or in a mesh in it’s own blueprint. Maybe your Character Movement component is not activated or the movement is disabled for some reason…

If all else fails just use the premade Player Character from the Third person or First Person projects provided by Unreal until you get this figured out.

Thanks so much for your help, pointing me in the direction of being stuck in something let me gradually delete asset after asset till I found one asset, what caused that I couldn’t move.
Again, thank you very much and have a great week. Best Regards