WASD not being captured


I have a problem with the inputs. I added a WidgetInteraction to my pawn but the event “AnyKey” is not being triggered for the keys “W”, “A”, “S” and “D”.

I am trying to make an EditableTextBox to take the input from the keyboard, but since I updated to v 4.14 there is no way to make it work.

Any ideas are welcomed

Is it actually firing the events on key press to call the functions?

No, the event is not being fired when I press those keys

I have just noticed that I can write weird symbols in my EditableTextBox normally, but normal letters are not being captured unless I double right click on the text field.


Double right click works because the keyboard focus is set in the function void FSlateEditableTextLayout::OnContextMenuClosed(TSharedRef Menu)

4 months later this is still not working for me. This bug was supposed to be fixed in the current engine version (4.16). Any update?

Yes, I have. That doesn’t fix the problem. If I click on the text box I can’t type anymore these letters.

My bad, seems to be fixed and now works as expected. Thanks!

Have you tried enabling input into that blueprint? Get player controller>enable input