Warning: r.RenderTargetPoolMin exceeded 432/400 MB

Every time I do anything (click anywhere in the content browser, compile a BP, click anywhere in a BP Graph) I get the message

“LogRenderTargetPool:Warning: r.RenderTargetPoolMin exceeded 432/400 MB (ok in editor, bad on fixed memory platform)”

in the Output log (which I always have opened on my third monitor).

I have no idea what this means, but it’s annoying.

Hello -

Recently we lowered the level from warning to something lower. It’s just good to know that the pool size is exceeding and it might cause minor stalls and a lot of video memory. You can run “vis” in the Output log to see what is allocated (Might be the screen resolution or many ReflectionCaptureActors). With “r.RenderTargetPoolMin=500” in the consolevariables.ini (or in console "r.RenderTargetPoolMin 500 ") you could prevent the printout.

Thank You

Eric Ketchum

Thanks! But if I run “vis”, it says only 100/400MB is allocated (and directly after the vis output I get the warning mentioned above again).
I don’t use any ReflectionCaptureActors and the Screen Resolution in the Editor is not really high, I have a 1080p screen.
I have one SceneCapture2D in my Level which renders to a RenderTarget2D with a resolution of 2048x2048, but this (hopefully) does not allocate 432MB of VRAM!

This is the output I get from “vis”:

link text

Hi -

No that one screen capture should not, can I ask what video card and driver you are running currently? Also, does resetting the r.RenderTargetPoolMin to 500 still produce the warning in your logs?

Thank You

Eric Ketchum

I have a AMD Radeon HD 7850 with Catalyst 14.4 driver. I know it’s one year old, but the newer versions are not compatible with some software.

After setting the r.RenderTargetPoolMin to 500 I don’t get the warnings in the log.

Hi John -

Instead of just the “vis” command, try using the “visRT” command, a window should pop up and see if the total there is at 432. visRT breaks down all render targets in the engine currently running.

Let me know -

Eric Ketchum


With visRT I indeed see all the RenderTargets and it says 408MB allocated… It seems the translucent Water Material from the Epic Water Examples is using a lot of RAM.



btw, if I click on one of the names on top, for example “size”, the engine crashes.

Hi John -

Thank you for the report of the crash. I have entered a report, UE-14237, for reference, and will let you know as soon as we have a successful fix for the issue.

Thank You Again -

Eric Ketchum

Got the same error message this day. It appears every time when i exit PIE or Standalone play. Its too strange, because i didn’t added any real actors content to the levels at all - i am currently only working with Blueprints (for creating Menus). The only visuals i have added - clickable boxes and their texts for menus. But even yesterday that error was not present. What i did today is just began a new menu for Options/Setting (actually duplicated my previously created Main Menu).