Warning level 4


Do you know how can I set the warning level to 4 ?
You know I need to get error in compile time when I have some variables which are not used anywhere etc.

The problem is when I open properties of my project there is no possibility to set the warning level.

Many Thanks…

Hey Vaclav-

Could you explain what you mean by setting the warning level? Are you referring to something inside the editor or in visual studio?


Hi Vaclav,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Visual Studio.

There is nothing else to say basically :slight_smile: Just set up Warning level 4. But UE project has different settings which dos not allow to setup warning level 4 in common way. So I need to know how I can sort it out

Hey Vaclav-

Since we use a custom build system (UBT) a lot of the default VS compiler behavior has been overridden to work with the code. The WindowsPlatformCompilerSetup.h is where various compiler warnings/errors have custom settings to allow VS to work smoothly with the engine. You can edit the settings in this file however you may also need to remove unused variables within the codebase to get it running. If you are able to do so then you may want to submit a pull request to make it easier to use these settings in the future.


Thanks for answer. Yes there is a lot of unused variables in UE :slight_smile: