Warning at launch: Can't find M_SimpleTranslucent.M_SimpleTranslucent

I upgraded my project from 4.15 to 4.20. But now, I am getting the warning dialog below when app launches on iOS. What can be wrong with this? It is somehow trying to read wrong file right? How can I fix this?

Message

Default Property warnings and errors:

Error: CDO Constructor

(CineCameraComponent): Failed to find /Engine/EngineDebugMaterials/M_SimpleTranslucent.M_SimpleTranslucent

Things that I already tried are:

  1. Clearing Intermediate and Saved folders.

  2. Tried setting bDontLoadBlueprintOutsideEditor to false

  3. Verified engine

3rd day, still working on this…

Looks like this is being called from here:. This is the only result from Sublime in Engine/Source folder.

Engine/Source/Runtime/CinematicCamera/Private/CineCameraComponent.cpp

Code is:

static ConstructorHelpers::FObjectFinder<UMaterial> PlaneMat(TEXT("/Engine/EngineDebugMaterials/M_SimpleTranslucent.M_SimpleTranslucent"));
FocusPlaneVisualizationMaterial = PlaneMat.Object;

But I have no idea why my project tries to launch a CineCameraComponent. I don’t have something like this. No occurences from search via Sublime Text.

Also, even if I apply M_SimpleTranslucent material to an object in my game, it shows WorldGridMaterial when packaged for iOS.

Resolved it but I have no idea how. I tried something but I don’t remember what I did.

I have the same problem right now:( Still don’t remember what you did?

Salih merhaba, çözüm var mı ben hala aynı problemi yaşıyorum.

Ok found it! Recently I’ve put a PakBlacklist-Shipping document inside Build > Android which was excluding debug materials. Since I’ve found the base blacklist over the internet, I didn’t know what it was excluding.

After some hours of digging, removed the line end the error is gone. Unfortunately around 5 MB added to final Android build.