Walls appearing white?

hey, I exported a house to ue4 for archviz, but some walls are white, while all walls should be some sort of warm gray which is the material assigned to them.

even though all of them have the same material, some appear white. why is this happening? I baked my lighting in production quality and it doesn’t help.

Do you get acceptable color values when you switch to unlit view mode? Perhaps try increasing the roughness value on these walls to see a more accurate color. It appears that the color of the light is simply washing it out. If you moved the direction of the sunlight, would the issue go away? If so, that tells you it is the directional light intensity.


yep, I tried all of that, didn’t work. tried modeling again in 3ds max and exporting, same problem. was about to give up when I thought of trying to apply a quick box uv map, and then it worked.

so apparently extruding splines in max doesn’t come with “generate mapping coordinates” enabled by default, and even if it is enabled, better apply a box map just in case.

I wasn’t too worried with uv mapping since datasmith automatically generates a second set of coordinates for the light map, but it doesn’t change the main uv channel obviously, so yeah, it was a lack of proper uvs

thanks steve

Ohhh gotcha! I typically add a “map scalar UV” modifier in 3DS prior to export to all of the geometry. This ensures that all geometry has consistent UV scale for textures. Maybe that will help you get consistent results as well.

apply a quick box uv map reimport the object, and then it will worked