Download

Wall Collisions Not Working with Pawn/ Character in Datasmith Export

Hello,

I have been creating an interactive environment for the last week or so through a 3D Scene exported from both Sketchup and 3dsmax. Things are looking good and going okay but when I started to set up wall collisions, I noticed the character in play mode would go through the walls I had just set up the collisions on. I had started the project with the FPS blueprint template. I did edit the BP to eliminate the camera, gun, shooting and such but that should not have impacted the collisions. I spent hours today searching the web for possible remedies and thought I found some but they did not work. I have selected on the wall mesh objects and opened in the editor to make sure collisions were enabled. Can anyone help me out with some thoughts on what to do?

Thanks!

if your player is not falling through the floor then the collision settings in the player should be fine. So compare the floor collision settings to your walls and see if you find any differences.
sharing some pics of the collision settings would help us help you.

Thanks Indie. I should have stated NONE of the collisions are working so I can walk down through the floor.

What collision settings would you like to see, the static mesh collision settings?

Also, here is something I tried. I created a new FPS project to test in 4.22. I migrated one of the wall meshes and the floor mesh over to the new project and dropped in the meshes. Went to game mode using the default character and the collisions I placed on these imported static meshes work fine. I am thinking something is missing from the initial project I originally set up such as a BP or some setting. I do not want to migrate the entire project over to a new clean project but if that is my only option to try, I guess I could.

So, stumbled into something that made the collision work. I pressed play again to simulate game and noticed there is a possess button to the right of the play gamemode button. I pressed it figuring I have nothing to lose. It worked. What I can’t figure out is that if you look at my screen shot, my archviz character has the autopossess on and I have it set to player 0. In the test project, I checked and when you press play, the possess button is automatically selected by default. Can someone please explain what happened and why?

if you look at the play button you’ll notice an arrow for a drop down list. on the list you’ll find a variety of play modes. the simulate play mode will stick you in a default pawn that allows you to fly around the level and is useful to test stuff when you don’t want to look through you’re character’s camera. for example if you have a first person character that can walk around but not fly, however you want to see what the tops of the trees look like for some reason. if you were stuck looking through the character’s camera you may not be able to see the tree tops easily.

the simulate play mode will stick you in a default pawn for testing, but if you click posses you jump into the gamemode character. I think f8 is the hotkey to toggle back and forth.

the “play” playmode will stick you in the character specified by the gamemode.

Thanks again Indie. However, I get what the possess button does but what I don’t understand is how the first person pawn must somehow have this set up as automatic when you press play to test the game. My question is why does my archviz pawn require me to press the possess button each time I hit play. Its just odd from what I had been doing.

just to clarify, when you say play you mean the play button without the gear icon?
With those setting if you’re clicking the play button without the gear icon then it should immediately posses the archvizcharacter. If it isn’t doing that then I think it may be a bug.

I just attached a screen shot of my screen. It is the play button with the gear. Again, this is UE 4.22 and things work fine in the other test project I opened, meaning, if you press play, the possess button to the right of play is automatically engaged since it says “eject” once play is pressed. In my current project, I had to press the possess button that is there whcih I did not need to do with other scenes.

I am starting to think there is maybe something missing in the Blueprint for the Character? When I created this project and started with the template, I deleted some of the character blueprint to get rid of the shooting, FP camera, the arms and some other actions. I am just not sure.

Did the play button have the gear in your other test project?
if it had the gear it shouldn’t autopossess the archvischaracter.

yes, it has the gear and yes, it is autoposessing the FPS character that comes with the default FSP Blueprint Project Template.

sounds like your fps project is the one acting abnormally.
did a quick test on my machine with 4.22 and the fps template works as expected.
the fps character is automatically possessed when clicking the play icon without the gear, while the play icon with the gear does not posses the fps character.

You are correct. If I do exactly as you said, it works like you mentioned in both my current project and the test project. Funny thing is in the test project it wroks the same if I press the play with the gear. Go figure but I have collisions. I appreciate the effort and time you gave to me. I would say some day I will get you back but I am just getting into the nitty gritty of UE so it will be a LONG time.