Walkable floor angle of a paper character is not working, please help

Hello everyone. I’m making a 2D game using paper sprites in UE4.10. My goal for today was to make some army tanks move up a hill. My problem is that the tanks keep getting stuck on the smallest of angles, even though I have the Walkable Floor Angle component set to 90.

Here are some pictures to explain what’s going on. The tank is a 2D paper character, since there is no 2D vehicle class.

The capsule component has collision enabled, but the sprite does not, since its shape is so much wider than the capsule.

These are the settings in the tank’s Character Movement component. They are similar to my player character’s settings, only the tank has the max possible walkable angle. My player character isn’t having any of these problems, it can walk over slopes just fine.

This is how I’m moving the tank. A 30-second timeline adds movement input, it seems to work right up until the tank hits an angle. Also, if the tank is on a slope, it just slides all the way down. Not sure if that’s relevant to this.

This is the angle that the tank gets stuck on. It’s a tiny angle, but every time the capsule (not the sprite) hits it, it just stops moving! As I mentioned earlier, I had this working earlier today. But I tried resizing the tank and the ground sprites, and that broke it. Now I can’t get it to work again, even by setting it back to its original size. Any help on this would be greatly appreciated! Thank you.

Hi there, what’s your collision like on your tank?

Also when you play, open the console (character ~) and type show collision to see if that doesn’t look weird.