Wait Gameplay Event never getting event

I started following a guide to learn the Gameplay Ability System and I noticed that Wait Gameplay Event never receives.

When I send off the Event, it prints out a string that shows the current BP_Character_base that is sending out the hit event to the Gameplay Event ‘Melee’.

This is the Gameplay Melee, when I get all actor info, then print it out, it shows the current BP_CharacterBase. When the actor melee attacks, it shows the exact BP_CharacterBase is being printed, thus showing it is indeed firing off, but the Wait for Gameplay Event never is received. The event tags are the same and I tried removing Match Exact in order to see if I could get anything to be received and havent had any luck.

At this point not sure if it’s an Engine bug, or something fundamental I missed, but I can’t find the issue on what’s going on.

Fixed it. It was because I didn’t add ‘public IAbilitySystemInterface’ in the C++ file.

1 Like

Can you explain where exactly you put this ‘public IAbilitySystemInterface’ ?
In header file or meaby in cpp file too?
Thanks for answer!

1 Like

Where?

Class extentions,
class OVERLORD_API AOLCharacter : public ACharacter, public IAbilitySystemInterface