Download

VXGI Testing

Finally got around to building Nvidia’s VXGI branch. Started playing around and thought I’d show a quick rundown. Here’s a vid:

[video]https://youtu.be/-wmbpL9OvNM[/video]

Hi there, Really impressive.

I tried to download this version now like 10 times. i cant make it work even if i follow the instructions exact.
I cant get up any VXGI shaders anywere, and i cant find those projects they talk about.

You have any How to do list to make this work?

Niiiice. Got a link to that sauce?

I’m not able to respond in detail at the moment, but there are some rough instructions in the comments of the youtube vid. Also, the link to the source download is in the about section of the video.

I tried latest build on this but could not get it to compile.

I get 4 compile errors :

Assertion failed: ModuleManager.IsModuleLoaded(ModuleName) [File:D:\UnrealEngine-4.8p3_VXGI\Engine\Source\Runtime\Core\Public\Modules\ModuleManager.h] [Line: 235]
Tried to get module interface for unloaded module: ‘D3D11RHI’

KERNELBASE.dll {0x00007ffde9178b9c} + 0 bytes
UE4Editor-Core.dll!FOutputDeviceWindowsError::Serialize() {0x00007ffdcd1f0b9f} + 0 bytes [d:\unrealengine-4.8p3_vxgi\engine\source\runtime\core\private
UE4Editor-Core.dll!FOutputDevice::Logf__VA() {0x00007ffdcd03de48} + 159 bytes [d:\unrealengine-4.8p3_vxgi\engine\source\runtime\core\private
UE4Editor-Core.dll!FDebug::AssertFailed() {0x00007ffdcd01a842} + 65 bytes [d:\unrealengine-4.8p3_vxgi\engine\source\runtime\core\private
UE4Editor-RHI.dll!FModuleManager::GetModuleChecked<IDynamicRHIModule>() {0x00007ffdd7956efe} + 222 bytes [d:\unrealengine-4.8p3_vxgi\engine\source\runtime\core\public
UE4Editor-RHI.dll!FModuleManager::LoadModuleChecked<IDynamicRHIModule>() {0x00007ffdd795729e} + 0 bytes [d:\unrealengine-4.8p3_vxgi\engine\source\runtime\core\public
UE4Editor-RHI.dll!PlatformCreateDynamicRHI() {0x00007ffdd798c31e} + 45 bytes [d:\unrealengine-4.8p3_vxgi\engine\source\runtime\rhi\private
UE4Editor-RHI.dll!RHIInit() {0x00007ffdd798f804} + 5 bytes [d:\unrealengine-4.8p3_vxgi\engine\source\runtime\rhi\private
UE4Editor.exe!FEngineLoop::PreInit() {0x00007ff73dc2aa32} + 0 bytes [d:\unrealengine-4.8p3_vxgi\engine\source\runtime\launch\priva
UE4Editor.exe!GuardedMain() {0x00007ff73dc2238b} + 15 bytes [d:\unrealengine-4.8p3_vxgi\engine\source\runtime\launch\priva
UE4Editor.exe!GuardedMainWrapper() {0x00007ff73dc2295a} + 5 bytes [d:\unrealengine-4.8p3_vxgi\engine\source\runtime\launch\priva
UE4Editor.exe!WinMain() {0x00007ff73dc341c9} + 17 bytes [d:\unrealengine-4.8p3_vxgi\engine\source\runtime\launch\priva
UE4Editor.exe!__tmainCRTStartup() {0x00007ff73dc351b9} + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]
KERNEL32.DLL {0x00007ffdeb0b13d2} + 0 bytes
ntdll.dll {0x00007ffdebf55444} + 0 bytes
ntdll.dll {0x00007ffdebf55444} + 0 bytes

Any ideas?

Are you on Win10 by any chance? I wonder if DX12 is mucking things up, based on “unloaded module: ‘D3D11RHI’”.