VS2015 compiler error: Failed to produce item .lib

The tracker shows it has been fixed in 4.16.2, please try updating.

I do have the same problem in 4.16.1 and VS17.

Same Problem in Unreal 4.16.1 I had to rebuild the whole project, hope it helps!

Can confirm, I have the same problem with 4.16.1 and VS15.

Have same problem with 4.16.3 and VS15.

4.17 VS2017 15.3.4 got that when rebuilding with development server configuration
Failed to produce item: F:\Unreal\UnrealEngine-4.17release\Engine\Plugins\Online\OnlineSubsystemUtils\Binaries\Win64\ProtoDedicated-OnlineSubsystemUtils.lib ProtoDedicated F:\Unreal\Projects\ProtoDedicated\Intermediate\ProjectFiles\ERROR 1

@harvelloken I don’t think this is the same issue. Did you also get the:

-waitmutex" exited with code 5. Please verify that you have sufficient rights
to run this command.

part of the message?

I am working with a custom version ue4.17.1 using code from VS215 within VS2017,

I am getting these errors that update 3 is required when I already updated the VS 2017

Severity Code Description Project File Line Suppression State
Error C2338 Visual Studio 2015 Update 3 is required to compile on Windows (http://go.microsoft.com/fwlink/?LinkId=691129) ShaderCompileWorker d:\unrealengine\enginebuilds\417\ue_4171_g\engine\source\runtime\core\public\Windows\WindowsPlatformCompilerSetup.h 19

Back again. UE4.22 with VS 2019…