Download

VS2013 error on startup

Hi,

So I get the following:

http://puu.sh/7E6Lo.png

I launch the engine.

Select New Project / Basic Code.

VS2013 starts and gives me the above error.

I then see the following error:

Intermediate\ProjectFiles est.vcxproj: The application which this project type is based on was not found. Please try this link for further information: http://go.microsoft.com/fwlink/?LinkID=299083&projecttype=8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942

Try deleting the ProjectFiles directory and re-generating the VS project files; I had the same thing happen and the cause seemed to be that my environment variables from Visual Studio were blank, so instead of getting paths to the VS tools they were all paths to my root drive (i.e. C:).

I have the same problem and, although the dialog specifies …\ProjectFiles\UE4.vcxproj, the error report seems to list all of the project files. I tried bleeds187 fix but there is no change. Can anyone think of something else that I could try? Thanks.

Edit: I’m not sure if this helps, but the UpgradeLog has the same error message for each of the project files: “The application which this project type is based on was not found.” I’m using Visual Studio 2013 Professional and have the required June 2010 DirectX runtime and dotNet 4.51 installed. Any ideas?

Edit 2: For anyone else with this problem, this answer on AnswerHub by joessu:
https://answers.unrealengine.com/questions/13425/could-not-open-visual-studio-2013-for-project-cunr.html
solved the problem for me (VCINSTALLDIR and VSINSTALLDIR were pointing at my VS2010 installation and they need to be pointing at VS2013).