Vs studio 2019 intellisense error 4.25.1 & 4.25.2

Intellisense in VS 2019 using UE 4.25.1 & 4.25.2, both does not auto find a class header like
#include "GameFramework/Actor.h"

it does not give error but intellisense does not list within header files.

but if you write with in <> then intellisense works.
also when you peek thru files if you go into engine side header files it shows thousand of error but if you go to definition and open up the header file there are no errors. It compiles OK too. If you close VS Studio 2019 and reopen from Editor it goes away.

Also as reported in other question it is extremely slow.

In order to make intellisense auto work I had to go project setting and go to NMake / Intellisense / Include Search Path then I added
*$(ProgramW6432)\Epic Games\UE_4.25\Engine\Source\Runtime\Engine\Classes*

I was able to fix some of the errors with intellisense by closing my project (both editor and Visual Studio), then right click on .uproject file → Generate Visual Studio files, and then restarting the project. Try it out.

Also, if you see animated icon in bottom left corner of your Visual Studio, that means Intellisense is gathering information. Wait for it to finish up.

i will try the “right click on .uproject file → Generate Visual Studio files…” isn’t that the same thing by doing the refresh VS Studio project files from the editor . but I will definitely try it out. I think most of the issues are memory related. I have a desktop and laptop. Laptop has 16 gb ram and desktop has 32gb ram and I don’t get some of the errors on the desktop.
Thnk …that was cool :slight_smile:

The problem is the 3rd prty librayr Physix. h has includes without whole directory structure Probably ok causetheir internal project setting include those So when Unreal Engine side is setup they include the neccessary filders but Game project setting does nit or cant see it thru wuth intellisesnse
I am sure if Unreal does some changeson the Game project setting or add them ro intellisenseincludes it can be resolved
I trust Unreal team they fix everything :slight_smile:

is me too.
I’m also in trouble, but I’m looking for a solution

I tried but same result; did not work :frowning:

That works great!men!