VS Code: "Unable to resolve configuration with compilerPath" and #include error

After updating to 4.27.1 I have been having trouble with VS Code.
Firstly, all the #include are giving error. I have tried all the fixes but nothing seems to work.
Secondly, the output tab on the bottom is saying “Unable to resolve configuration with compilerPath “C:\Program”. Using “cl.exe” instead.” multiple times.


Everything is working fine in the engine, so it appears to be a problem with vscode. This is only happening in this version of the engine. Is it a bug or something?

Here is what the properties file looks like, in case it is related.

Im not sure this is a serious problem, just need help understanding what is going on as it is really annoying for the whole page to be marked red with errors.

Thanks a lot!

Hi! Got the same issue here, seems that the spaces from the command paths from compileCommands_Default.json are causing the compilerPath problem

1 Like

any solution?

See this post : UE 4.27 how to fix issues in visual studio code: "red squiggles" and "Unable to resolve configuration with compilerPath C:\Program"

Adding VS Code extension named <> by rhighs solved the issue for me. Once added that extension we need to manually check the (UEIntellisense Fixes: Enable Fixes) and (UEIntellisense Fixes: Enable Optional Fixes) and restart the Code to solve the errors.
Link :

1 Like

i got the solution right here :

GameDev.tv – 24 Mar 21

#include errors detected in VS Studio Code

Could you try down grading to the latest stable release? 1.2.2? You can do that via this menu

its a very simple problem and you can fix it by simply down grading version of the C/C++ extension to 1.2.2

1 Like