[VR] Widget Interraction Component misfires for onMouseEnter and onMouseLeave

When using a “Widget Interaction” component with your camera, looking at a 3D widget will constantly trigger “onMouseEnter” and “onMouseLeave” as long as you are looking at the widget.

This behavior does not mimic the non-VR interaction with UMG widgets and mouse controls.

To perform this test:

  • Create a widget
  • Add an onMouseEnter and onMouseLeave event with respective print strings
  • Create an actor
  • Add a widget component and assign it the widget created above
  • Add a widget interaction component to the player pawn’s camera that you’re using
  • Enable debug mode on it for ease of seeing results

From this point forward, add the actor somewhere in your level, size it so you can see it clearly and play.

To see the expected result, add the widget to the viewport instead.

Hello MajinSephiroth,

I ran through the steps above and I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean blank project (not VR template)?
  2. If so, could you provide any small steps that may have been missed in the original post?
  3. Could you provide screen shots of any settings/blueprints/widgets that may be involved?

As far as I can tell, this is not happening in a blank project, time to see what’s going on.

Hello MajinSephiroth,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks,