VR teleport ray trace collides with opacity mask

Hi everyone,

I am trying to get the ray trace from the VR teleport (from template) to go through voids created using a material’s opacity mask.

More generalized question: I’m having difficulty getting the opacity mask on a material to work properly with collision.


You can specify within the teleport raytrace what kind of objects will give successful hits.

Buuuut the actual problem you’re having is that a raytrace doesn’t care about opacity, you’d need a custom collision mesh that mimics the form of your object to get this to work.

E.g. a round mesh for a snowflake instead of a square polygon.

Thanks for your response!

Ah ■■■■ I had a bad feeling about that… So I managed a work around and ran into another similar issue.

I have a landscape that I don’t want the VR navigation to interact with at all. I have all collision turned off and navigation turned off as well. It prevents navigation but the teleport arc is still stopping at the landscape when I want it to go all the way through. I’m not sure if there’s a setting I’m missing but “no collision” doesn’t seem to do the trick.

As a work around I suppose I could export the landscape as a mesh and import it to get the desired result but I feel like there must be a way to have the teleport arc ignore this landscape entirely. (maybe by tag?)


So I was able to have the teleport arc ignore the landscape by turning it into “World Dynamic” instead of “World Static”. Problem solved!

That’s great! Please mark this question as resolved :slight_smile: