VR support still causing problems in 4.19


it’s been now 4 versions (since 4.16) that I am being punished by Unreal Engine for owning a VR headset. Every single version I did create a thread about the issue, but it’s still not resolved.

Basically, as long as you own a VR headset, such as in my cause Oculus Rift, but you do not intent to develop any VR games, your life is made a bit harder by Unreal Engine. Every single time I launch Unreal Editor, both Oculus home and Steam VR apps automatically start along with editor. Both Oculus home and Steam VR are very heavy and cumbersome programs that slow down editor loading, freeze windows for a few seconds, steal window focus and take a while to close down. Every single launch of Unreal Editor, therefore, is made a very frustrating experience.

I don’t see why is so difficult to initialize a VR device only when it’s actually used in a given project. Why does it need to be initialized on every editor launch even when the user does not have any intention of using it. Especially Oculus home causes severe performance hit as long as the plugin is not disabled, but even when I disable both Oculus and SteamVR plugin, I still get Oculus Home and SteamVR opened on UE4 launch.

This almost make me regret that I ever bought a VR headset, because while I enjoy using it, and I hate how it complicated my work with Unreal Editor :frowning:

Start SteamVR and go into settings->Developer. There is a checkbox “Start SteamVR when an application starts.” Uncheck it.
I haven’t looked but I believe Oculus Home has a similar setting.

Bear in mind, when you want to use a VR app just start SteamVR manually and get it running before launching the app (or launch from inside SteamVR Home).

a very annoying problem without any solution from Epic or Oculus, and I don’t know what other developer are doing to fix this problem:(

Disable the VR plugin for that headset in the project. There, done. It’ll never pop up again, or at least it shouldn’t.

So what if I am working on a VR project, but still I don’t want Oculus home pooping up every time I test my level, its very distracting and annoying to close it every time, a simple fix solution is urgently needed in this regard…

So here we are again, 4.24 introduced yet another punishment for VR users. All the terrible bloat such as oculus home and steam VR will now launch on EVERY SINGLE **** 4.24 startup even BEFORE ANY PROJECT IS LOADED!!! It immediately switches my computer audio to my oculus headset and freezes the PC for a few seconds while all that **** loads, slowing down launch of the engine. Why the hell would VR be needed for a **** project select screen?!?!