Download

VR-Ready C++/Blueprintable Pawn with common VR functions. Also good as a SteamVR project template.

Ok, here’s my log. Crashes again if I disable SimpleHMD plugin.
RunebergVR_Teleporter.cpp line 50

https://pastebin.com/55QCenrT

Wow! Outstanding! Just what I’ve been looking for!

I was just wondering if you could please add couple of comfort options for the locomotion and turning, such as the tunnel effect type thing that Google Earth VR and Adr1ft uses as well as snap/comfort turning where the screen fades to black, turns X amount of degrees and fades from black to the new direction that the player is now facing.

Thankfully I’m completely immune to simulation sickness but it would be great to have these as comfort options for those playing my game that aren’t as lucky. :smiley:

Thanks a lot for doing all of this, it’s very much appreciated!

Thanks for the feedback thesnowdog1, I appreciate it.

I’ve added your requests to my feature backlog :slight_smile:

Will make some convenience functions but note that “Fade to Black” (or any color really) is relatively straight forward with standard UE Blueprints – Check out the following:

Hope that helps!

Cheers,
Rune

Hi laggyluk - Thanks for that, saw an issue with me checking for the name/type of the HMD in the Teleport component before I check if one is available/connected. So I think what’s happening on your end is you’re getting crashes when your HMD is not active or UE is unable to detect it. The SimpleHMD plugin acts as a proxy HMD when you enabled it and hence no crashes…

I updated the code to fix this issue (version 2.73) and is now up in GitHub for both UE4.16 & UE4.17. Marketplace updates to follow in the next couple of days. Let me know though if you’re still experiencing the crash on your end.

Cheers,
Rune.

Nice! Thanks for the link Rune, I’ll check that out! :smiley:

I think I’ve stumbled on another teleporter bug others cryptically mentioned. When I start the game while sitting on edge of my ‘play area’ (that’s where my PC is located) I can’t seem to get to where I’m pointing at, like there’s an offset caused by me not being in center of the room. I’ve made a video where It teleports me out through the wall as result.
If I move to center of the play area and teleport from there it works as expected.
https://www.youtube.com/watch?v=HBY8CQIO4rk

Anyone has an idea how to remove velocity from held objects after teleporting? They kind of rubberband to position and spill beer.

[quote=“laggyluk, post:26, topic:62407”]

I think I’ve stumbled on another teleporter bug others cryptically mentioned. When I start the game while sitting on edge of my ‘play area’ (that’s where my PC is located) I can’t seem to get to where I’m pointing at, like there’s an offset caused by me not being in center of the room. I’ve made a video where It teleports me out through the wall as result.
If I move to center of the play area and teleport from there it works as expected.https://youtube.com/watch?v=HBY8CQIO4rk[/QUOTE]

HI @laggyluk - this was a bug in an old version of the plugin. By any chance you are still using the 4.15 version of the Engine?

Not sure if I understand your setup correctly, but there’s a GrabbedObject reference in the Grabber component which you can use to disable physics and such. I’ll have a look as well though as it sounds like a bug from my end.

Sorry for the delay in replies btw — I seemed to have stopped receiving notifications on this thread.

I’ve recorded it in 4.17 with I think most recent plugin from github but not 100% sure, my vive rig is in a a box again so can’t verify atm.

As for disabling physics for teleporting time that was first thing I’ve tried but had bunch of problems with it, in the end in my use case it’s ok to disable tick on actors for 2seconds after teleport.

Btw here’s how my project looks, thought you might want to know what is your plugin used for :slight_smile:
https://www.youtube.com/edit?o=U&video_id=lZjXpiC70RA

Hi laggyluk!

Thansk for the clarification, I’ve received another report of the teleport offset issue, was meaning to get through this on the weekend but got some work stuff come up. Will try to have a look at over the week. the bug may have been reintroduced in a later update for some reason. Will verify, fix and get back to you on this.

Awesome work on the project! May I share this link in the GItHub, Marketplace & upcoming web documentation of the plugin ?

Cheers,
Rune.

@laggyluk Looks great! I love the mood and the interactions you have created. I can tell you put a lot of thoughts and efforts into that. Keep up with the good job!

Thanks guys! @runeberg feel free to use it

Hi laggyluk - btw, is this the same title “Alchemist Defender VR”?

Nope, it’s just that every time I start to work on something at least 3 bigger projects based on similar idea are released.

Hi runeberg,

awesome plugin! I have a request (something similar was just posted by user owen.global on the marketplace forum just yesterday): Could you take a look into gravity in combination with Pawn collision? I’m using your gravity enabled 360MovementComponent with the ‘uneven flooor’ option (to use with stairs), but I’d also like to use standard pawn collision (by setting RunebergVRPawn’s CapsuleCollider to Collision Preset ‘Pawn’ ideally).
At the moment, when I try that, the gravity FloorChecks don’t seem to play nicely with the CapsuleCollider hitting the ground (lots of jittering and falling through the floor). Or maybe I’m missing something here. Is there a way to enable standard Pawn collision on the RunebergVR_Pawn that I haven’t seen? In all your demos, you use NavMeshBounds to stop the player from running into walls, but I haven’t found one with proper WorldStatic object collision. As it is, my Pawn can walk nicely along the floor and up uneven terrain, but it doesn’t collide with my world scenery.

P.S.: I’ve pulled your github repo and made a small addition: Uneven terrain now checks for a “maximum step height”, so you can walk up steps that are 20 units high for example (configurable ofc), but can’t walk up a box that’s 100 units high. It’s really just two lines of codes. Would you be interested to add this?

Cheers,
Bigtoe

HI… You can perhaps use a custom collision channel to ensure that you are ignoring the floor in your collisions and an then define walls as something that would trigger a stop on the movement component.

For thep ull request, yes please, go ahead, I would love more contributors to this plugin :slight_smile:

Alright, I made a pull request with my changes.

Hi Rune, hi other VR fans,

so, I’m playing with the plugin (UE4.18, plugin v3.04 as of today) and I’m having some issues with the Teleport functionality.

What I have is:

  • a basic level with a navmesh (with all areas that I want to access showing “green” as in the picture)
  • a basic pawn that I want to use to teleport around
  • some (imported from fbx) StaticMeshActors to walk on

What is happening is:

  • default “floor” mesh works fine for navigating
  • some of the imported actors don’t work at all (Outside_Floors_013 in example)
  • some of the imported actors work fine (Outside_Floors_002 in example)
  • some of the imported actors (where they overlap with the ‘floor’ mesh) work fine is some places but not in others (Outside_Floors_015 in example)

When navigation does work, I’m experiencing some additional issues:

  • The beam and teleport particle seems to be ‘stuttering’ - as if it has to make many many attempts to find a suitable teleport location) when navigating on the “floor” mesh. I figure this is strange because the navmesh is very simple
  • When I adjust parameters in the RecastNavMesh-Default actor (specifically: reducing the Agent Radius from 35 to, say, 10 to allow for navigating narrow spaces) the navmesh result is as expected, but Teleport functionality breaks down completely

I have uploaded a stripped version of the project in the link below – perhaps someone wants to take a look at what I’m doing wrong here? I have been struggling with the navigation for a while now so any help would be greatly appreciated!

Cheers,
Warner

319029261c17aaab5009c2f585ea4635f54a232b.jpeg