VR Player Pawn is set to floor level after the first Teleport with the Vive controller

Hey, so as i said above i have an open VR Template Projekt. Ive imported my Blender Projekt into it and was setting up based on a youtube video. The green floor wich indicates where you can teleport to works fine. The center of my pawn is on the floor lvl aswell like in the videos ive seen but the moment i start the VR Play im in the floor or basicly a bit above ground level. Now in the Videos that ive seen i should be on my Real Life Hight level because the Vive is calibratet to my floor.

Someone knows a fix or a guide wich works where i can move in my VR World with my controller on a normal height level?

If you’re using the ‘new’ VRPawn you may check the Event BeginPlay part of the VRPawn BP. When I first used that pawn I had the same problems as you, because I didn’t set the ‘Is Head Mounted Display Enabled’ to True.

If that is the case, you need to enable it via Enable HMD.

image

1 Like

Perfect worked for me, thank you :+1:

Glad it worked :slight_smile:

If you don’t mind, please don’t forget to mark your question as ‘Resolved’. This will help other user find the right answer faster. (and I believe there will be more questions about this specific problem :nerd_face: )

1 Like