VR Mirror Standard Output


I’m wondering if there is a way to make the VR mirror on the PC output to fullscreen without distortion. ie. I’m aware of these commands:

1. HMD mirror mode 0': default
2. HMD mirror mode 1': Undistorted stereo
3. HMD mirror mode 2' : Undistorted single eye
4. 'HMD mirror 960x1080' : sets mirror window to desired dimensions

What i essentially want it what HMD mirror mode 2 provides, but without the distortion. Just basically having the mirror look like a regular game preview, whilst the Oculus still previews as normal.


An answer to this would be great.

For now, I’m recording with OBS on hmd mirror mode 2, I up the resolution via r.SetRes xx, then bring into After Effects to downscale width by 50% (thus removing the lame stretch). This leaves me with a square aspect ratio, so then I crop to get a nice 16:9 ratio. Unfortunately I naturally lose resolution through this process, and end up with a ‘zoomed in’ perspective because of the crop.

NOT ideal. Could anyone shed light on their processes? <3

For an art installation I’m trying to achieve the same. Have you found a solution ?

Hi all,

As of yet I’m still unable to find a solution to this. If anyone has any info, please let us know.

I would also like to know if this can be done. Has anyone had any suggestions yet?

Ive seen the Showdown VR Demo shows the Undistorted Single view on the user’s second monitor (when using the Showdown Template in Unreal 4.10).
I dont know how Epic did that. Has anyone found the answer?

Just to update this thread since it is a top google search result:
I believe this is working properly in Unreal 4.11 and the Oculus DK2.

I have added 2 console commands to the Main level blueprint (see screenshot).
I have also the resolution of my game preview window (in the editor settings) to 1080x1080. Any square aspect ratio can be used. This way the single-view will not be distorted.

If anyone has any further tips please do post them here!

In Unreal 4.12 there is a new mirror mode. This produces an undistored full screen output with a minimal circular black section on the sides.

Console command:
HMD mirror mode 4

mirror mode 4 is great, however I have another problem now.

On my machine calling any “HMD mirror mode” command stops any mirroring, both in editor and in build.
However it works perfectly fine after moving project/build to different machine.
I need to remove Saved folder to restore it.
Did anyone have that issue?

When I set the mode to 4 my mirror window freezes by enabling stereo. Do you have the same issue ? It also changes my display (I have a wide view) in my headset which is obviously not the expected result.

EDIT: I’m using HTC Vive

Here, too.
As soon as I enter “HMD mirror mode” into the console screen goes black/freezes.

Solved: HMD mirror mode command works only with Oculus

Type "hmd mirror ". Number is mode.

Thanks that helps for the Oculus, but has anyone managed to get this working on VIVE?

I also am working with a Vive and the mirror window is now stuck as black even if I remove the console command. Any help is real appreciated :slight_smile:

@michaelwbell - If I could, I would hand you a Virtual Beer. Thx for this

Thank you very much!