Download

VR Frame Rate and Physics actors Help plz

Howdy all;
I’m working on a VR game and I have many many physics collision sphere actors flying around. So I know that will be an issue but I am trying to properly tackle the frame rate as best as I can.
There are two different scenarios that produce two different issues.

Scenario A:
Project Settings > General Settings > Framerate
Smooth Frame Rate = OFF
Use Fixed Frame Rate = ON
Fixed Frame Rate = 75
Smoothed Frame Rate Range = 22 - 62
Min Desired Frame Rate = 35

Also in the level blueprint I am using at startup the
console command t.maxfps 75 ]

Issue: The frame rate is never fully glass smooth but smooth enough to get by. When enemy count gets around 250+ The whole scene goes into slow motion and the motion controller geometry starts to slow down its frame rate. The headsets speed is always super fast and the headsets framerate is super high. But the world, enemies, and controllers frame rate slows down. But it all slows down evenly so its still useable without causing motion sickness. This is the route I’m going with currently.

Scenario B:
Project Settings > General Settings > Framerate
Smooth Frame Rate = ON
Use Fixed Frame Rate = OFF
Fixed Frame Rate = 75
Smoothed Frame Rate Range = 22 - 62
Min Desired Frame Rate = 35

No console command at startup being used

Issue: The frame rate is super crazy glass smooth up until about 100+ enemies. The frame rate of the headset remains super fast. But the frame rate of the world, enemies and controllers slows way down and jitters and skips unevenly causing a lot of motion sickness really quickly.

That all said, if anyone know what I should be doing to optimize or how I might be able to get things running better I would really truly appreciate any advice or ideas. Sorry it was such a wordy question.
Thank you so much for your time
Lenny