VR breaks simulate play

When having played in VR preview, simulate play is broken til a restart. You can’t select nor manipulate anything in the viewport, as if the real mouse position is offset by a lot to the visual cursor position. It is possible that this is only happening with the Vive. Also, the motion controller positions of the end of VR preview take over in the other play modes instead of being on their default positions.

Similar situation: I’m also using the Vive and the cursor is offset to the right of the actual position in simulation mode. For example, in the level view, when the mouse is over “Launch” then “Build” is highlighted. The cursor is offset everywhere in the UE4 window but is fine on the rest of the desktop. The offset makes debugging AI or blueprints quite difficult. The project is presently using 4.11, it worked fine in 4.10.

I experienced this myself yesterday, but I think this could be connected to nVidia’s drivers 365.10, which I updated to yesterday. While I was on 364.72, I had no such issue.

To clarify on the issue, what I see when I press “Play” in simulate mode, the whole UI (of the editor, not the game!) resolution seems reduced (buttons look larger and so on), and indeed there is an offset in the position of the buttons (I had to aim the cursor between “Blueprints” and “Cinematics” for the “Stop” button to be highlighted). If I reduce the window size, the UI gets shrank horizontally and everything looks narrower! This is really weird.

@Davision, could you change this question into a “Bug Report” instead of “Using UE4” so that it gets the required attention?

In 4.11, my work-around was to to unplug the Vive then launch the editor. When I was done debugging AI-BT, I’d close the editor and plug the Vive back in. The obvious drawback was the vrPawn was not active when the Vive was unplugged.

Alternately, the old faithful of adding print statements and checking the output log after the session worked…

I had this issue sometimes with Unreal 4.9.2 and Oculus CV1! Since i updated my nvidia driver to 388.31 it happend every time i hit play. VR-Preview worked though.
I just unplugged the Oculus USB connection and everything works great now!