Download

Voxel Terrain has Artifacts

Hey guys,
I’ve been messing around with MagicaVoxel (MagicaVoxel) to create a voxel terrain for a little project. When I export it directly into an obj, and then into UE4 the tri/vert count is extremly high (Tri: ~14K, Vert: ~21K), so I took up a tip from a guy who said try importing the .vox file into VoxelShop (https://blackflux.com/) and export it as Low Poly .dae file. Did that, converted to fbx, and it has indeed only ~3K tris and ~8K verts, but I get those artifacts:

Does anybody now how to fix it? Or can anybody tell me if the first Tri/vert count is ok? I think it’s way to high for a voxel terrain :frowning:

Maybe try first importing it into blender or something and welding the vertices. That might cause something similar, and would increase your vertex count significantly.

Wait. You mean if I weld those vertices, I may get the same result + a higher vertex count?

Lol no I was typing on my phone. It could FIX those issues.

Hello @iUltimateLP,

I am the creator of VoxelShop. There is a setting when exporting called “Use Texture Padding”, that should do the trick.

If you are working in Unity you might also need to adjust some settings. There is lots of useful information for Unity import from VoxelShop on the forums:
https://blackflux.com/forums/

I am not monitoring this thread closely, so if you have any other questions or issues please post on the forums or on github:

Thanks,
flux

After further thought this might be a setting in unreal that is causing this.

Would you mind sending me the exported *.dae file so I can take a look at it?