Download

Volume Lines Showing while playing in editor

Hello,

I’m not sure if this is the place to ask this (if not, please delete, my mistake). I have a Nav Mesh Bounds volume and a Procedural Foliage Spawner in my level and when i play in the editor to test, the volume lines show in game. How do i keep this from happening?

The Nav Mesh Bounds Volume shouldn’t normally show up in-game. Does it go away if you bring up the console (`) and type in the “show Volumes” command?

Hi, thanks for replying. When i use that command in game, my Post Processing Volume becomes visible also. It doesn’t seem to affect the Nav Mesh Bounds Volume, whether i toggle it on or off.

To be clear, i’m on UE version 4.25.3.

In that case, it could be a bug. Have you tried creating a new project and seeing if the Nav mesh volume is visible?

Yes that was one of the first things i tried. The volumes don’t show in a new project. I tried placing a fresh new nav mesh bounds also and it made no difference. There must be some setting that i’m missing or something. I can’t seem to figure it out…

I have figured this out. I have an AI blueprint which manages AI for my game and it was causing the Nav Mesh Bounds to be visible during gameplay because the collision box for it was not ticked for Hidden In Game.