VOIPTalker Mic pickup very quiet with poor quality audio playback 4.26

I’m adding **VOIPTalker **to a new project in order to add in-game voice with spatialization.

The sound quality of the audio is very poor (I’ve increased it to 24000Hz in the VOIP sample rate in **Project Settings **to no great improvement.
The pickup of the mic is also extremely poor, requiring me to pretty much put the mic into my mouth and talk loud to even get any sort of pickup.

For my tests I’ve tried three different microphones all of which work fantastically well in all other cases (Games, Discord, Zoom, Streaming, etc…)

It feels like I’m missing a step where I can better configure the mic prior to it being captured. If I use an Audio Capture Component, to test the sound loopback locally, the quality is much better, the pickup is good, but as far as I know (The documentation on all of this seems pretty much nonexistent), Audio Capture Component’s are not used for the VOIPTalker.

I have it running over two PCs on LAN, setup using Unreal’s Session Networking to carry the voice audio. (AFAIK Networking via IP does not support Audio transfer)

Here’s some of my Blueprints to help show how this was done.

The Mic Threshold is setup as -10 by default (though I’ve tested from -1 to -120) and hooked up to keys that can increase/decrease it live.

The Attenuation Settings are as follows, though I have tested it without and the mic still sounds just as poor, but without the effects.


The Effect Chain just has a simple pan preset.

The issue here wasn’t in the setup it was missing extra steps to configure the microphone. It seems that the default settings for the mic can be way off.

In blueprints the solution is to use cvars to tweak the mic setup to change the configuration, which is probably going to differ between setups and advisable to expose these settings to a user configurable UI.

To help resolve this, run the game and press tilde ~ then step through the voice. cvars and tweak the settings until a good solution is found.