Visual studio throws reading violation exception on atidxx64.dll while editor is working

I have compiled UE4.10 with Visual Studio 2015 (community version) on Windows 10.
Compiling goes smoothly, even if it took a long time to finish. When I start debugging the UE4 project, the editor loads but then Visual Studio immediately interrupts saying a message of the likes of

"Exception thrown at 0x00007FFCB8FE09C8 (atidxx64.dll) in UE4Editor.exe: 0xC0000005: Access violation reading location 0x0000008C5EC98820"
The editor seems to be working well meanwhile, even if VS has stopped execution in debug mode. Going to the line of exception, VS just asks me for a pdb file and I can't supply one (obviously). I don't know if that actually stops some functions of the UE Editor, the only thing that I tried so far (since it's been quite the problem lately with VS2015 for me) is to disable the antivirus. Another thing that I should probably mention is that I also have installed the engine through the Epic client. My video card is a AMD R9 285. Does anybody know what is the problem, how can it be fixed, or (even if it doesn't look like) if it is just a meaningless error and has no effect whatsover over the engine/compilation/shading/etc.?


After restarting my computer, the issue reappears. It seems to be happening when the Epic Games Launcher starts (might be a coincidence tough).
Also, looking at the stack frame this time I found a parent function that’s calling the one that I can’t see in the DLL.
The function seems to be always the same and it’s called FRHIResource::Release, in the RHIResources.h header.

The debugger breaks it at its last line:

return uint32(NewValue); (line 55)
Looking at NewValue, VS returns 'identifier "newValue" is undefined'. I wonder why the program breaks in atidxx64.dll and not in this line tough. The value of "newValue" is defined in the line 38, and it's defined as:
int32 NewValue = NumRefs.Decrement(); (line 38)
and NumRefs is a private variable that currently holds the value of 0. Hopefully this helps something. Maybe I have to reinstall Visual Studio or UE4? Hopefully not, the installation process is quite long..


I have a few questions regarding this issue:

  • Have you attempted a fresh install of Visual Studio 2015?
  • Have you gotten this same error after restarting your computer?
  • Are you seeing the same error when debugging non-UE4 projects?
  • Is your Windows fully up-to-date?

Hello, thank you for the reply.
I’ve update the response to answer some of your questions and to add some information I’ve found out.
To answer your other questions: the software on my end seems to be updated fully; I don’t have the same issues in other projects; I haven’t reinstalled VS2015.

Are you debugging a project, or the engine itself? Could you run me through the steps that you are taking when you are seeing this error?

Also, it would be worth it to attempt a reinstall of both VS and UE4, as it is possible something got corrupted during the installation process.


I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this post. For any new issues, please create a new Answerhub topic.

Have a great day