Download

Visual studio not triggering breakpoints (C++)

Hello everyone,

I’m new to this forum so please forgive me if this is not the right place to be posting this. I’ve switched to UE4 from Unity a few of days ago and I’ve been trying to get debugging to work within *Visual Studio 2015 community edition *since then but I was unable to. I followed these steps:

  1. Switch to DebugGame Editor solution configuration (Also tried with other configurations)
  2. Build project
  3. Attach VS to UE4 Editor by going to Debug->Attach Process
  4. Set a breakpoint
  5. Run the game within UE4 (Have also tried running the game beforehand)

The breakpoint is not triggered and the tooltip “The breakpoint will not currently be hit. No symbols have been loaded for this document” is shown.

I would greatly appreciate it if someone could help me out.
Thanks!

I dont know how well this works…
For me, I just debug using the log file and console, but Interested if anyone was able to hook in the visual studio debugger myself.

What I do after launch from editor, you can open VS studio, then close the anterior instance of the one htat did run the launcher, and hit run directly form visual studio, so this time, the process is already attached to VS and you can put break pints that works.

As mentioned, the general workflow would be to just build the solution, then hit F5, which will load up the project in the editor (circumnavigating the launcher) with the debugger attached.

That said, using Attach To Process should work just fine too. The thing is, when you run the editor from the launcher, or open your project by double clicking the project file, it will load the Development Editor configuration dlls for your project. This configuration is partially optimised, which can cause problems with debugging.

I’d suggest trying to run the project from VS first. If you still have an issue, there is something wrong with your set up, or you’re putting a breakpoint in code that isn’t getting built.

Thank you, that seems to work fine. I appreciate your help!

Is VS 2015 for Windows 10 the full version of VS?