Visual Studio deinstall removes the launcher


this is the second time I’m having this problem. A few days ago, some programs were removed from my harddrive without any permission, including Visual Studio 2015. I wanted to reinstall it, but some error occured so I had to deinstall it, before I could install it again (it was corrupted). But when I deinstalled Visual Studio 2015, it also removed the Epic Games launcher. I wanted to know if this was a coincidence, but it was not. I tested this out again and the same problem occured. I don’t know if this is a known bug, but since I didn’t found anything about it, I wanted to share this with Epic Games. Maybe you can also help me with that problem. I’m also wondering if this problem is connected to my other missing programs, because they were located in the same directory as Visual Studio.

Kind regards,


Is there a chance that your Epic Games Launcher is being installed inside of your Visual Studio directory? Are you sure that the Epic Games Launcher is actually being uninstalled and it’s not just that the shortcut to it is being deleted? Can you check the Programs and Features section of the Control Panel to ensure that it is or isn’t installed?


no, the launcher isn’t installed inside my Visual Studio directory. I’m sure that it was uninstalled, because I searched for the .exe but couldn’t find it. The whole “Launcher” folder in D:\Program Files(x86)\Epic Games\Launcher was just removed. And as I tried to use Recuva (a tool for data recovery) I saw all the missing files from that launcher folder.

And yeah, I checked the programs in the control panel. The programs are still in the list, but if I try to change/uninstall them it’s said that the program was already removed - and that is what happened.

When you go to uninstall Visual Studio, what exact process are you using to do so? Does it mention anything about Unreal when you do so? Also, when you install Visual Studio, where are you installing it from?

Well, I reproduced this problem once and I used a different process each time to uninstall it, but the result was the same:

First I had the problem that Visual Studio didn’t open properly by starting it manually (it said I should reinstall it) and when I tried to use it through the editor there was a error message: “No compiler found”. So I clicked the button “Install Visual Studio 2015”. When the setup started, it didn’t appear as if the program was uninstalled, because I had the options change, repair and uninstall as usual.

But since I had to reinstall VS, I clicked uninstall and the launcher was removed after that.

Later I wanted to reproduce this problem, so I uninstalled VS with the normal WinInstaller process through the control panel → same result: the launcher was closed (I had opened it to prevent it from being removed) and then removed…

Yeah, I also thought it could be some kind of virus, but I scanned my computer with avast and malwarebytes anti-malware a few days ago and today aswell.

You’re not the only one who is confused about this: I have never experienced such a problem before.
But I’m pretty sure there is a problem somewhere in the engine. I just tried to install and uninstall VS manually (I downloaded the community version from MS) but this time the launcher was still there. This problem only occurs, if I install and uninstall VS through the editor.

Still thank you for your efforts

This is definitely perplexing as I’ve never seen Windows act this way when it comes to installed programs. After asking around for suggestions from other people on the team, a few mentioned that it may be good to ask when you last ran a full virus scan on your computer? I’ll continue looking into what could cause this kind of behavior but this is all I could think of at the moment.

Due to this being an issue with the launcher itself and not the editor, it would be best if we moved this issue over to a report on

Please use the “Email Us” button to create a report and use the “Launcher Support” issue type. This will make the report go straight to the team that oversees the launcher who should be able to help you more with this issue.

Edit: Posted just after your last message, so you can ignore this. Thank you narrowing the reproduction down. I’ll try to get the same thing to occur locally.

Alright. If you want me to send a report after all then just tell me. I’m looking forward to your response.

Alright. Thank you for that information, I’ll try to find a solution there. If I can be of any help for solving or reproducing this problem please let me know.

In the meantime, I would suggest sticking with Visual Studio Community. If I remember correctly, the version that is installed by the editor is the Express version which does miss out on quite a few things. Community is just not something we include with the engine due to it requiring an account and a separate EULA.

I’m curious to know if Community is working out correctly for you. Also, I’m currently testing to see if I can get the same behavior that you are seeing when installing Visual Studio from the editor.

In the past days I tried two different versions of the VS community with update 3 (one of it the express version). I downloaded them both from microsoft and installed them as usual. Both times everything worked perfectly and the launcher was still installed, but the problem is that the engine does not recognize my VS then. Could that be because I used the German version? Anyway, this time the launcher was still there at least.

I also asked in the VB forums if someone else had this problem, but they didn’t. They also advised me to try the download from MS, but no external VS is being recognized by the editor…

I hope that helps


We’ve identified the uninstall issue being a bug on the Visual Studio side, and a fix has made into the Visual Studio 2015 Update 3(download here). The problem is that VS uninstalls the Epic launcher when it’s not supposed to. VS looked for the regkey which indicates the Epic launcher is installed and thought it was installed by VS and then attempted to uninstall it. In the fix this uninstall logic is removed on the VS side.

Sorry for any inconvenience this has caused! Please let us know if Update 3 fixes the problem you’ve seen.


| Program Manager
| Visual Studio team, Microsoft


Just saw your latest comment and I’m glad to hear Update3 fixed the uninstall issue for you!

About the new problem where the engine does not recognize your VS install, can you elaborate on that a bit more? What error did you see and where?

Thanks, | Program Manager | Visual Studio team, Microsoft


If I want to create a new class there is standing “No compiler found”. I have done a little bit of research and I thought it could be solved using the environment variables of the computer, because they are used to tell the editor where the compiler is located. Is that true?



To be honest I’m not sure which env variable or anything else the Unreal engine looks for to tell where the VC compiler is located. I’m going to need some input from the Unreal team. Let’s follow up offline over email? Can you send me a quick mail at ?


Hello, the environment variables needed to find the compiler should be:

Variable name: VS140COMNTOOLS
Variable value: C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\Tools\

As well as adding the following entry to the Path variable under System variables:


Thank you!

I checked the variables. They are as they should be now. But I have currently installed the VS from the editor. I’m going to uninstall the current VS and install the version from MS again so that I can check whether the environment variables are the problem.