Download

Visual Studio 2019 Freezes After Compiling

Recently, I’ve run into a productivity-crippling issue where visual studio freezes and becomes completely unresponsive after compiling my code. I always get a “Visual Studio is busy” notification but it never resolves itself. To get it running again requires that I force it to shut down and reopen it, but it still always freezes after compiling. This only happens if I’ve made changes to the code and never if I compile it without having made any.

I really have no idea how to diagnose this so if anyone can help, that would be great :grinning:

Edit: Compiling from the editor works and the problem only occurs when compiling from visual studio.

I didnt have that problem yet, but i would try to reinstall Visual Studio.
If that doesnt fix it u can always try contacting tech support of UE or VS.

You can also switch from VS to Rider for Unreal Engine, i find it 100 times better then VS and its free while it is still in Early Access, so definitely worth checking out (it may also not fix your problem tho)

1 Like

I’ve tried Rider for Unreal and I really like it. The thing about it is, when I joined the early preview, I was given an evaluation period of one month, after which my session with it was limited to 30 minutes at a time! Obviously, that doesn’t work. So, in order to use it, JetBrains expects me to purchase a license. That seems rediculous to me for something that’s still in Early Access… Back to Visual Studio I go.

Does nobody else have that happen? :face_with_raised_eyebrow:

Anyway, guess I’ll go reinstall VS. Thanks for your help :grinning:

1 Like

I got this happening and I have updated VS2019 and stopped. It appeared again two weeks after another update from VS2019 appeared available and I had to rollback with previous backup.

It is a Visual Studio bug, otherwise it shouldnt be fixed when they updated VS2019, so I think it is nothing to do with Epic unfortunately.

2 Likes

Just thought that I would give an update to say that reinstalling VS worked. :+1:

2 Likes