Download

visual studio 2019 (14.22.27905) must be installed to build this target.

upon generateprojectfiles we are getting … visual studio 2019 (14.22.27905) must be installed to build this target.

We have been having this issue on 1 of 2 workstations.

one workstation was built on 2017 community with no fails and works fine.

The other system will not build with either vs2017 or vs2019. either version gets the error.

We have removed github, source and VS several times, doing clean installs of both versions. to no avail.

We read all the current forums about changing the buildconfiguration.xml, adding the 14.22 build tools and Command linker, etc.

We can build 4.23 source with either version of VS but neither origin/4.25 or release will build.

HELP!!!

So it seems that we were close a few times. but finally hit the jackpot.
there were 2 copies of the buildconfiguration.xml.

one was in the \unrealengine\engine\saved\unrealbuildtool folder.

and the other was in the AppData\Roaming\Unreal Engine\UnrealBuildTool folder.

the first one was listed as the correct place in several of the forums.
the second was the one actually affecting the build. it was showing the correct 14.22.27905 but still gave the error message.
simply removing the buildconfiguration.xml from the folder did the trick.
~whew

2 Likes

Thank you! Removing the buildconfiguration.xml file worked for me too!