Visual Studio 2015 failed to load solution

I’ve recently got 4.10, and already had Visual Studio 2015 installed. When I try to create a C++ project and it gets to the part where it opens Visual Studio and loads the solution it give me the error: “One or more projects in the solution were not loaded correctly. Please see the Output Window for details.” I then hit OK and in the solution explorer both the UE4 project and my project say “Failed to load”. In the output window it just says “error: One or more errors occurred.” I’ve tried creating multiple projects, all with the same result. I’ve also uninstalled and reinstalled Visual Studio and the engine. If anyone can help, it would be much appreciated. Thanks.

I for got to add that if you expand one of the projects in the solution explorer, it says “This project requires user input. Reload the project for more information.”
Reloading the project does nothing.

I ended up just formatting and restoring my pc. It is working fine now. I have no Idea what was going on.